Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Low Eclipse UI frame rate?(How do I remove the frame rate cap eclipse seems to have?)
Low Eclipse UI frame rate? [message #1823190] Sat, 21 March 2020 18:06 Go to next message
Dan Negura is currently offline Dan NeguraFriend
Messages: 1
Registered: March 2020
Junior Member
Eclipse has always had a very low UI frame rate when scrolling through the code. The frame rate seems to be capped at around 15 or 10. A video of it can be seen below, as well as a comparison of other applications scrolling.

The video format itself reduces the frame rate down from 60 and there still is a visible difference. It almost feels like Eclipse is being run through a cheap vm. There is also click delay. I know it's not my computer because I tried it on other people's computers and the same thing happens there.

Is this a know issue? Is there a fix for it?
Re: Low Eclipse UI frame rate? [message #1823196 is a reply to message #1823190] Sun, 22 March 2020 04:24 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31366
Registered: July 2009
Senior Member
On my Windows 7 machine, I don't get the impression that Eclipse scrolls differently from any other application. Are you on Mac or Linux? There's no parameter/mechanism to control "frame rates". I've not heard anyone complain about this issue before either. But I don't monitor the SWT forum:

https://www.eclipse.org/forums/index.php/f/100/


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Viewing session is not available or expired : BIRT Server
Next Topic:"Failed to create Java Virtual Machine
Goto Forum:
  


Current Time: Thu Aug 13 06:21:30 GMT 2020

Powered by FUDForum. Page generated in 0.02596 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top