Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Debugger problem
Debugger problem [message #1823180] Sat, 21 March 2020 11:23 Go to next message
Sonya Singh is currently offline Sonya SinghFriend
Messages: 1
Registered: March 2020
Junior Member
Im new to eclipse on Mac OS and I was wondering if anyone could help me out with a debugger issue I am having. I'm currently on Mac Mojave, and I installed my gdb files. I receive this error when trying to launch the debugger:

Failed to execute MI command:
-file-exec-and-symbols /Users/matt/eclipse-workspace/rain/Debug/rain
Error message from debugger back end:
"/Users/matt/eclipse-workspace/rain/Debug/rain": not in executable format: file format not recognized
Failed to execute MI command:
-file-exec-and-symbols /Users/matt/eclipse-workspace/rain/Debug/rain
Error message from debugger back end:
"/Users/matt/eclipse-workspace/rain/Debug/rain": not in executable format: file format not recognized
"/Users/matt/eclipse-workspace/rain/Debug/rain": not in executable format: file format not recognized

Thanks & Regards
Sonya from ischedule

[Updated on: Tue, 24 March 2020 05:54]

Report message to a moderator

Re: Debugger problem [message #1823187 is a reply to message #1823180] Sat, 21 March 2020 16:44 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30993
Registered: July 2009
Senior Member
What language are you using? If it's C/C++ it's likely better to ask on the CDT forum:

https://www.eclipse.org/forums/index.php/f/80/
Re: Debugger problem [message #1823473 is a reply to message #1823187] Fri, 27 March 2020 05:55 Go to previous message
David VavraFriend
Messages: 1071
Registered: October 2012
Senior Member
I don't use Mac OS but the error is:
"/Users/matt/eclipse-workspace/rain/Debug/rain": not in executable format: file format not recognized

Is /Users/matt/eclipse-workspace/rain/Debug/rain the executable?
Are you sure it was built without errors?
Was it built to run on a Mac or some other target?
Previous Topic:2020-03 Arduino Editor unresolved symbols
Next Topic:My HelloWorld project won't compile
Goto Forum:
  


Current Time: Sun Mar 29 16:41:20 GMT 2020

Powered by FUDForum. Page generated in 0.21179 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top