Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » formatter generatestub problem(the formatter generator section in mwe2 file produces invalid output)
formatter generatestub problem [message #1822952] Tue, 17 March 2020 10:17 Go to next message
Fco Javier Santos is currently offline Fco Javier SantosFriend
Messages: 2
Registered: March 2020
Junior Member
if I add:
formatter = {
generateXtendStub = true
}

on my .mwe2 file, it adds
org.xtext.example.mydsl.formatting2
into my MANIFEST.MF file and that package is nowhere to be found.

How can I fix that?
Re: formatter generatestub problem [message #1822979 is a reply to message #1822952] Tue, 17 March 2020 15:08 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13641
Registered: July 2009
Senior Member
anything in the log?

can you try?

formatter = {
generateStub =true
generateXtendStub = true
}


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: formatter generatestub problem [message #1822980 is a reply to message #1822952] Tue, 17 March 2020 15:10 Go to previous messageGo to next message
Tamas Miklossy is currently offline Tamas MiklossyFriend
Messages: 114
Registered: February 2016
Senior Member
Could you try to set both variables to true?
formatter = {
    generateStub = true
    generateXtendStub = true
}

Similar as configured on the Xtext examples shipped with the Xtext framework.

[Updated on: Tue, 17 March 2020 15:11]

Report message to a moderator

Re: formatter generatestub problem [message #1823293 is a reply to message #1822980] Tue, 24 March 2020 12:59 Go to previous messageGo to next message
Fco Javier Santos is currently offline Fco Javier SantosFriend
Messages: 2
Registered: March 2020
Junior Member
That works. Thanks a lot. That solves my problem.

Just a comment. If I try:

formatter = {
generateStub = true
generateXtendStub = false
}

It does fail. I don't see the point to have a configuration to decide if the stub is Xtend if you can't have a non Xtend stub.
Re: formatter generatestub problem [message #1823294 is a reply to message #1823293] Tue, 24 March 2020 13:11 Go to previous message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13641
Registered: July 2009
Senior Member
formatter = {
generateStub = true
generateXtendStub = false
}

will log an error to the console when running the workflow. see https://bugs.eclipse.org/bugs/show_bug.cgi?id=481563


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Previous Topic:Xtext YAML Grammar
Next Topic:Add EAnnotation in generated Ecore
Goto Forum:
  


Current Time: Wed Oct 28 14:41:23 GMT 2020

Powered by FUDForum. Page generated in 0.01928 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top