Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » Bug report - Note gets detached when reconnecting edges
Bug report - Note gets detached when reconnecting edges [message #1821304] Mon, 10 February 2020 15:15 Go to next message
Avi Shaked is currently offline Avi ShakedFriend
Messages: 116
Registered: October 2019
Senior Member
Hi,

In my models, I sometimes add notes from the general Palette (by using the yellow note symbol), and attach them to elements (including to edges).

I have noticed that upon reconnection of element-based edges (changing source or target of the edge), the attached note becomes detached (so that the note remains, but is no longer connected to the edge). I suspect this is a bug that should be addressed.

Thank you,
Avi
Re: Bug report - Note gets detached when reconnecting edges [message #1821310 is a reply to message #1821304] Mon, 10 February 2020 15:44 Go to previous message
Steve Monnier is currently offline Steve MonnierFriend
Messages: 492
Registered: May 2011
Senior Member
Hello,

Indeed I reproduced the same issue. I guess that a new graphical element is created on refresh and the note attachment is therefore not reconnected to the new edge. You can file a new bugzilla about it.

Best regards,
Steve


Steve Monnier - Obeo
Need training or professional services for Sirius?
http://www.obeodesigner.com/sirius
Previous Topic:Tabular view representation
Next Topic:"element" bug in Reconnect Edge
Goto Forum:
  


Current Time: Sun Oct 25 18:00:51 GMT 2020

Powered by FUDForum. Page generated in 0.01537 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top