Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Skiping classes when debugging DSL code
Skiping classes when debugging DSL code [message #1821135] Thu, 06 February 2020 08:27 Go to next message
Loredana Hozan is currently offline Loredana HozanFriend
Messages: 20
Registered: January 2019
Junior Member
Hello, i have a DSL, which generates java classes and trace files. All the files are packaged in a jar and deployed to a processing engine. The debugger works as expected, it debugs the generated java classes and uses the trace files as a wrapper. The issue is at certain time in the process, because everything is executed inside the engine, the debugger tries to debug the java classes from the engine and that is not the desired outcome. I have tried to use step filters to skip the classes from the engine, but it does not work. Is there a way in which i could skip those?
Re: Skiping classes when debugging DSL code [message #1821136 is a reply to message #1821135] Thu, 06 February 2020 08:32 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13643
Registered: July 2009
Senior Member
how did you implement the step filters? did you debug why they dont work

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Skiping classes when debugging DSL code [message #1821137 is a reply to message #1821136] Thu, 06 February 2020 09:06 Go to previous messageGo to next message
Loredana Hozan is currently offline Loredana HozanFriend
Messages: 20
Registered: January 2019
Junior Member
Hello, thanks for answering. I used the step filters that are present for the java debugger in eclipse.
Re: Skiping classes when debugging DSL code [message #1821139 is a reply to message #1821137] Thu, 06 February 2020 09:36 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13643
Registered: July 2009
Senior Member
then you should debug why the step filters are not working as expected.
i always found them buggy/sluggish but thats a jdt problem


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Skiping classes when debugging DSL code [message #1821227 is a reply to message #1821139] Fri, 07 February 2020 12:48 Go to previous message
Loredana Hozan is currently offline Loredana HozanFriend
Messages: 20
Registered: January 2019
Junior Member
Thank you for your input
Previous Topic:Xtext prefences pages
Next Topic:Serialization requires names to be "more unique" than other parts of the language implemen
Goto Forum:
  


Current Time: Fri Oct 30 05:43:58 GMT 2020

Powered by FUDForum. Page generated in 0.02288 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top