Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Error running mwe2
Error running mwe2 [message #1819295] Sun, 12 January 2020 11:34 Go to next message
Augustin Rialan is currently offline Augustin RialanFriend
Messages: 1
Registered: January 2020
Junior Member
Hello,

When I attempt to generate the Xtext artifacts by running the mwe2 file, I recieve the following error:

Downloading ANTLR parser generator failed: Server returned HTTP response code: 504 for URL: htttp://download.itemis.com/antlr-generator-3.2.0-patch.jar
Please install the feature 'Xtext Antlr SDK' manually using the external updatesite:

'htttp://download.itemis.com/updates/'.


And even the link it give me it impossible to join manually


Thank you for your help
Re: Error running mwe2 [message #1819408 is a reply to message #1819295] Tue, 14 January 2020 17:34 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13637
Registered: July 2009
Senior Member
hi, there was an outage of download.itemis.com on Jan. 12th.
should be working again now


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Error running mwe2 [message #1828414 is a reply to message #1819408] Tue, 09 June 2020 12:20 Go to previous messageGo to next message
M Schubanz is currently offline M SchubanzFriend
Messages: 1
Registered: December 2017
Junior Member
Same here. As far as I can see, the download server is down again, to let those who are affected know.
@Christian Dietrich I'm going to write to the official info@itemis eMail. Let's see who will handle this faster, you or the guys from the service office ;-)

> Task :org.xtext.example.mydsl:generateXtextLanguage
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by com.google.inject.internal.cglib.core.$ReflectUtils$2 (file:/home/slize/.gradle/caches/modules-2/files-2.1/com.google.inject/guice/3.0/9d84f15fe35e2c716a02979fb62f50a29f38aefa/guice-3.0.jar) to method java.lang.ClassLoader.defineClass(java.lang.String,byte[],int,int,java.security.ProtectionDomain)
WARNING: Please consider reporting this to the maintainers of com.google.inject.internal.cglib.core.$ReflectUtils$2
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
0    [main] INFO  text.xtext.generator.XtextGenerator  - Initializing Xtext generator
6    [main] INFO  lipse.emf.mwe.utils.StandaloneSetup  - Adding generated EPackage 'org.eclipse.xtext.common.types.TypesPackage'
88   [main] INFO  lipse.emf.mwe.utils.StandaloneSetup  - Registering project org.xtext.example.mydsl at 'file:/home/slize/git/swt-prak-ws18----language-modelling-/backend/target/xtext-lsp/org.xtext.example.mydsl/'
88   [main] INFO  lipse.emf.mwe.utils.StandaloneSetup  - Registering project org.xtext.example.mydsl.tests at 'file:/home/slize/git/swt-prak-ws18----language-modelling-/backend/target/xtext-lsp/org.xtext.example.mydsl.tests/'
88   [main] INFO  lipse.emf.mwe.utils.StandaloneSetup  - Registering project org.xtext.example.mydsl.ide at 'file:/home/slize/git/swt-prak-ws18----language-modelling-/backend/target/xtext-lsp/org.xtext.example.mydsl.ide/'
94   [main] INFO  lipse.emf.mwe.utils.StandaloneSetup  - Using resourceSet registry. The registered Packages will not be registered in the global EPackage.Registry.INSTANCE!
337  [main] INFO  clipse.emf.mwe.utils.GenModelHelper  - Registered GenModel '....eclipse.org/Xtext/Xbase/XAnnotations' from 'platform:/resource/org.eclipse.xtext.xbase/model/Xbase.genmodel'
340  [main] INFO  clipse.emf.mwe.utils.GenModelHelper  - Registered GenModel '.....eclipse.org/xtext/xbase/Xtype' from 'platform:/resource/org.eclipse.xtext.xbase/model/Xbase.genmodel'
352  [main] INFO  clipse.emf.mwe.utils.GenModelHelper  - Registered GenModel '.....eclipse.org/xtext/xbase/Xbase' from 'platform:/resource/org.eclipse.xtext.xbase/model/Xbase.genmodel'
352  [main] INFO  clipse.emf.mwe.utils.GenModelHelper  - Registered GenModel '.....eclipse.org/xtext/common/JavaVMTypes' from 'platform:/resource/org.eclipse.xtext.common.types/model/JavaVMTypes.genmodel'
720  [main] INFO  erator.parser.antlr.AntlrToolFacade  - downloading file from '....download.itemis.com/antlr-generator-3.2.0-patch.jar' ...
Downloading ANTLR parser generator failed: Connection refused (Connection refused)
Please install the feature 'Xtext Antlr SDK' manually using the external updatesite:

                '.....download.itemis.com/updates/'.

(see .....eclipse.org/Xtext/download.html for details)
778  [main] INFO  erator.parser.antlr.AntlrToolFacade  - downloading file from '....download.itemis.com/antlr-generator-3.2.0-patch.jar' ...
Downloading ANTLR parser generator failed: Connection refused (Connection refused)


P.S.:
Had to tweak the download links, as eclipse forums did not allow to include it.
Re: Error running mwe2 [message #1828432 is a reply to message #1828414] Tue, 09 June 2020 14:42 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6874
Registered: July 2009
Senior Member
Hi

What version of Java do you use?

I use java 8 and have not seen anything similar. The message suggests it is Java tightening up requiring longstanding code practices to be revised.

Regards

Ed Willink
Re: Error running mwe2 [message #1828435 is a reply to message #1828432] Tue, 09 June 2020 15:11 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13637
Registered: July 2009
Senior Member
Can you please retry. Server was down and Monitor was broken

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Error running mwe2 [message #1828484 is a reply to message #1828435] Wed, 10 June 2020 14:17 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13637
Registered: July 2009
Senior Member
its broken again

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Error running mwe2 [message #1828490 is a reply to message #1828484] Wed, 10 June 2020 16:00 Go to previous message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13637
Registered: July 2009
Senior Member
And should be up again

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Previous Topic:LiveScope and new Resources
Next Topic:"The method or field Literals is undefined for the type Class<...>"
Goto Forum:
  


Current Time: Mon Oct 26 04:47:16 GMT 2020

Powered by FUDForum. Page generated in 0.02119 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top