Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » cannot update from 4.4 to 4.5
cannot update from 4.4 to 4.5 [message #1817262] Tue, 19 November 2019 14:11 Go to next message
nimo mayr is currently offline nimo mayrFriend
Messages: 13
Registered: April 2019
Junior Member
I tried to upgrade papyrus from 4.4 to 4.5 using update site:

http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/2019-09

When performing the update, the following is shown:

Your original request has been modified.
"Papyrus for UML" is already installed, so an update will be performed instead.
Cannot complete the install because one or more required items could not be found.
Software being installed: Papyrus for UML 4.5.0.201909110825 (org.eclipse.papyrus.sdk.feature.feature.group 4.5.0.201909110825)
Missing requirement: Papyrus SashEditor 2.1.100.201909110825 (org.eclipse.papyrus.infra.core.sasheditor 2.1.100.201909110825) requires 'osgi.bundle; org.eclipse.emf.common.ui [2.18.0,3.0.0)' but it could not be found
Cannot satisfy dependency:
From: Papyrus Core 3.0.0.201909110825 (org.eclipse.papyrus.infra.core.feature.feature.group 3.0.0.201909110825)
To: org.eclipse.equinox.p2.iu; org.eclipse.papyrus.infra.core.sasheditor [2.1.100.201909110825,2.1.100.201909110825]
Cannot satisfy dependency:
From: Papyrus infra 3.0.0.201909110825 (org.eclipse.papyrus.infra.feature.feature.group 3.0.0.201909110825)
To: org.eclipse.equinox.p2.iu; org.eclipse.papyrus.infra.core.feature.feature.group [3.0.0.201909110825,3.0.0.201909110825]
Cannot satisfy dependency:
From: Papyrus for UML 4.5.0.201909110825 (org.eclipse.papyrus.sdk.feature.feature.group 4.5.0.201909110825)
To: org.eclipse.equinox.p2.iu; org.eclipse.papyrus.infra.feature.feature.group [3.0.0.201909110825,3.0.0.201909110825]

How can I update papyrus by update site without reinstalling?
Re: cannot update from 4.4 to 4.5 [message #1817263 is a reply to message #1817262] Tue, 19 November 2019 14:29 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 913
Registered: February 2011
Senior Member
Hi,

You need to use the Simultaneous Release update site, which contains both Papyrus and all its potential dependencies, with consistent versions:

https://download.eclipse.org/releases/2019-09/

HTH,
Camille


Camille Letavernier
Re: cannot update from 4.4 to 4.5 [message #1817270 is a reply to message #1817263] Tue, 19 November 2019 16:06 Go to previous message
nimo mayr is currently offline nimo mayrFriend
Messages: 13
Registered: April 2019
Junior Member
Thanks. It works.
Previous Topic:Update site for Papyrus Software Designer tests support
Next Topic:Help with templates
Goto Forum:
  


Current Time: Thu Dec 12 01:17:55 GMT 2019

Powered by FUDForum. Page generated in 0.02297 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top