Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » eTrice » C++ Tutorial build problem(Unable to build the template tutorial on Linux)
C++ Tutorial build problem [message #1816544] Wed, 30 October 2019 23:55 Go to next message
Tim Butler is currently offline Tim ButlerFriend
Messages: 9
Registered: March 2012
Junior Member
Hello,

I'm trying to build the C++ template tutorial project on Linux, and running into this build error:
/home/tim/Eclipse/workspace-cdt/org.eclipse.etrice.runtime.c/src/platforms/MT_POSIX_GENERIC_GCC/etDatatypes.h:33:10: fatal error: bits/siginfo.h: No such file or directory

Any idea how I might go about solving this?

System details:
Eclipse: C++ IDE 2019-09
eTrice: 3.0.0
gcc: g++ (Ubuntu 7.4.0-1ubuntu1~18.04.1) 7.4.0

Thanks and best regards,
Tim Butler
Re: C++ Tutorial build problem [message #1816608 is a reply to message #1816544] Fri, 01 November 2019 12:10 Go to previous messageGo to next message
Tim Butler is currently offline Tim ButlerFriend
Messages: 9
Registered: March 2012
Junior Member
To follow up, I simply commented out the offending #include of bits/siginfo.h and was able to successfully build and run the C++ template tutorial.

Regards,
Tim
Re: C++ Tutorial build problem [message #1816679 is a reply to message #1816608] Mon, 04 November 2019 20:22 Go to previous messageGo to next message
Henrik Rentz-Reichert is currently offline Henrik Rentz-ReichertFriend
Messages: 261
Registered: July 2009
Senior Member
Hi Tim,

thanks for the update.

We are tracking this issue with
https://bugs.eclipse.org/bugs/show_bug.cgi?id=552599

Best,
Henrik

Tim Butler wrote on Fri, 01 November 2019 08:10
To follow up, I simply commented out the offending #include of bits/siginfo.h and was able to successfully build and run the C++ template tutorial.

Regards,
Tim

Re: C++ Tutorial build problem [message #1816907 is a reply to message #1816679] Mon, 11 November 2019 15:52 Go to previous message
Henrik Rentz-Reichert is currently offline Henrik Rentz-ReichertFriend
Messages: 261
Registered: July 2009
Senior Member
We have fixed this issue and released a patch version eTrice 3.0.1.

Thanks for reporting this.

Henrik
Previous Topic:Project in actual release
Next Topic:[announce] eTrice 3.0.1 released
Goto Forum:
  


Current Time: Fri Dec 09 22:46:00 GMT 2022

Powered by FUDForum. Page generated in 0.03918 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top