Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Eclipse RAP and EMF tools(Incompatibility beetwwen Eclipse RAP and EMF tools???)
Eclipse RAP and EMF tools [message #1816116] Mon, 21 October 2019 13:12 Go to next message
antonio guillen is currently offline antonio guillenFriend
Messages: 54
Registered: January 2014
Member
Hi all

If I install Eclipse IDE for RCP and RAP, and if after I install the plugins for EMF modelling capabilities, and if I load a project containing EMF models it's impossible after exit to reload Eclipse I have the following log:

eclipse.buildId=4.13.0.I20190916-1045
java.version=1.8.0_211
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=fr_FR
Framework arguments: -product org.eclipse.epp.package.rcp.product
Command-line arguments: -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.rcp.product

This is a continuation of log file D:\Tony\Travail\LABO_RAP\SpotWorkspace\.metadata\.bak_0.log
Created Time: 2019-10-21 13:59:12.284

!ENTRY org.eclipse.oomph.p2.core 4 0 2019-10-21 13:59:12.284
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Exception in org.eclipse.oomph.p2.internal.core.P2CorePlugin$Implementation.stop() of bundle org.eclipse.oomph.p2.core.
at org.eclipse.osgi.internal.framework.BundleContextImpl.stop(BundleContextImpl.java:919)
at org.eclipse.osgi.internal.framework.EquinoxBundle.stopWorker0(EquinoxBundle.java:1029)
at org.eclipse.osgi.internal.framework.EquinoxBundle$EquinoxModule.stopWorker(EquinoxBundle.java:370)
at org.eclipse.osgi.container.Module.doStop(Module.java:658)
at org.eclipse.osgi.container.Module.stop(Module.java:520)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.decStartLevel(ModuleContainer.java:1885)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1760)
at org.eclipse.osgi.container.SystemModule.stopWorker(SystemModule.java:275)
at org.eclipse.osgi.internal.framework.EquinoxBundle$SystemBundle$EquinoxSystemModule.stopWorker(EquinoxBundle.java:202)
at org.eclipse.osgi.container.Module.doStop(Module.java:658)
at org.eclipse.osgi.container.Module.stop(Module.java:520)

Do you know why? It's very anoying because I am oblige to have two session of Eclipse open, one for RAP second for EMF

Thnaks a lot for your help

Antonio

Re: Eclipse RAP and EMF tools [message #1816124 is a reply to message #1816116] Mon, 21 October 2019 14:45 Go to previous messageGo to next message
Markus Knauer is currently offline Markus KnauerFriend
Messages: 152
Registered: July 2009
Senior Member

Hi Antonio,

at the first quick look I see only p2 and Oomph in your stacktrace.
Based on that it is probably better to ask on their forum first, e.g. the Oomph forum can be found at [1], and they are typically very helpful.

[1] http://eclipse.org/forums/eclipse.oomph

Thanks and regards,
Markus


--

Twitter: @mknauer23 and @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Eclipse RAP and EMF tools [message #1816125 is a reply to message #1816124] Mon, 21 October 2019 15:21 Go to previous message
antonio guillen is currently offline antonio guillenFriend
Messages: 54
Registered: January 2014
Member
Hi Markus

In the next log you will see that the pb comme from EMF/sirius.... This run was before the previous one....

!SESSION 2019-10-20 23:24:05.847 -----------------------------------------------
eclipse.buildId=4.13.0.I20190916-1045
java.version=1.8.0_211
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=fr_FR
Framework arguments: -product org.eclipse.epp.package.rcp.product
Command-line arguments: -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.rcp.product

This is a continuation of log file D:\Tony\Travail\LABO_RAP\SpotWorkspace\.metadata\.bak_0.log
Created Time: 2019-10-20 23:25:57.031

!ENTRY org.eclipse.core.runtime 4 0 2019-10-20 23:25:57.033
!MESSAGE Invalid input url:platform:/plugin/org.eclipse.sirius.ui.editor/icons/SiriusFile.gif
!STACK 0
java.io.IOException: Unable to resolve plug-in "org.eclipse.sirius.ui.editor".
at org.eclipse.core.internal.runtime.PlatformURLPluginConnection.parse(PlatformURLPluginConnection.java:64)
at org.eclipse.core.internal.runtime.FindSupport.find(FindSupport.java:293)
at org.eclipse.core.runtime.FileLocator.find(FileLocator.java:206)
at org.eclipse.jface.resource.URLImageDescriptor.getStream(URLImageDescriptor.java:155)
at org.eclipse.jface.resource.URLImageDescriptor.getImageData(URLImageDescriptor.java:123)
at org.eclipse.jface.resource.URLImageDescriptor.access$3(URLImageDescriptor.java:121)
at org.eclipse.jface.resource.URLImageDescriptor$URLImageDataProvider.getImageData(URLImageDescriptor.java:77)
at org.eclipse.swt.internal.DPIUtil.validateAndGetImageDataAtZoom(DPIUtil.java:404)
at org.eclipse.swt.graphics.Image.<init>(Image.java:732)
at org.eclipse.jface.resource.URLImageDescriptor.createImage(URLImageDescriptor.java:271)
at org.eclipse.jface.resource.ImageDescriptor.createResource(ImageDescriptor.java:182)
Previous Topic:RAP and Application.e4xmi
Next Topic:Error on Custom Variant for Grid
Goto Forum:
  


Current Time: Sat Dec 14 16:34:08 GMT 2019

Powered by FUDForum. Page generated in 0.01926 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top