Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » egit plugin install fails (Not able to install egit plugin due to dependency missing )
egit plugin install fails [message #1814679] Mon, 16 September 2019 09:51 Go to next message
Karthick Sekar is currently offline Karthick SekarFriend
Messages: 2
Registered: September 2019
Junior Member
Below is the error i am getting while trying to install egit.

Cannot complete the install because one or more required items could not be found.
Software being installed: Git integration for Eclipse 5.4.2.201908231537-r (org.eclipse.egit.feature.group 5.4.2.201908231537-r)
Missing requirement: Git integration for Eclipse 5.4.2.201908231537-r (org.eclipse.egit.feature.group 5.4.2.201908231537-r) requires 'org.eclipse.core.runtime [3.12.0,4.0.0)' but it could not be found

Thanks in advance.
Re: egit plugin install fails [message #1814682 is a reply to message #1814679] Mon, 16 September 2019 10:28 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3512
Registered: July 2009
Senior Member

Your version of Eclipse is too old. Update to the current release.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: egit plugin install fails [message #1814683 is a reply to message #1814682] Mon, 16 September 2019 10:41 Go to previous messageGo to next message
Karthick Sekar is currently offline Karthick SekarFriend
Messages: 2
Registered: September 2019
Junior Member
I use Rational Application Developer and my version is up to date.
Version: 9.5
Build ID: RADO95-I20150908_2025

[Updated on: Mon, 16 September 2019 10:42]

Report message to a moderator

Re: egit plugin install fails [message #1814686 is a reply to message #1814683] Mon, 16 September 2019 11:36 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30551
Registered: July 2009
Senior Member
Your RAD version may well be up-to-date (though 2015 is not exactly all that recent). But that's too old to install the latest version of EGit. There are lots of old versions available:

https://download.eclipse.org/egit/

You'd need to find out which version will install, e.g., is quite old

https://download.eclipse.org/egit/updates-4.0/
Re: egit plugin install fails [message #1814690 is a reply to message #1814686] Mon, 16 September 2019 13:17 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3512
Registered: July 2009
Senior Member

You might also want to verify whether it's a feature you can already enable from within the Installation Manager. The documentation for the current release, 9.7, mentions eGit specifically as being included.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: egit plugin install fails [message #1815026 is a reply to message #1814690] Tue, 24 September 2019 11:19 Go to previous messageGo to next message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 161
Registered: August 2016
Senior Member
Nitin Dahyabhai wrote on Mon, 16 September 2019 13:17
You might also want to verify whether it's a feature you can already enable from within the Installation Manager. The documentation for the current release, 9.7, mentions eGit specifically as being included.

Interesting; hadn't seen that. RSA 9.7 is based on Eclipse Oxygen, so I wonder what version of EGit they'd serve. Probably 4.8 or 4.9. Those were current back then: Oxygen is already two years old.

In any case newest EGit from the normal EGit update site (either 5.5.0 or nightly) installs and works fine on RSA 9.7. No need for IBM's Installation Manager at all.

RSA 9.5 was based on a much older Eclipse version (4.4, i.e., Eclipse Luna), so recent EGit versions won't install. The latest that might work on RSA 9.5 would be EGit 5.0.3 from September 2018, which can be installed from the old 5.0.3 update site.
Re: egit plugin install fails [message #1815038 is a reply to message #1815026] Tue, 24 September 2019 16:04 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30551
Registered: July 2009
Senior Member
Looking at the metadata

https://download.eclipse.org/oomph/archive/simrel/egit.aggrcon/http___download.eclipse.org_egit_updates-5.5/org.eclipse.egit.feature.group_5.5.0.201909110433-r.html

I.e.,
    <required namespace="org.eclipse.equinox.p2.iu" name="org.eclipse.core.runtime" range="[3.12.0,4.0.0)"/>
    <required namespace="org.eclipse.equinox.p2.iu" name="org.eclipse.core.resources" range="[3.11.0,4.0.0)"/>
    <required namespace="org.eclipse.equinox.p2.iu" name="org.eclipse.core.filesystem" range="[1.6.0,2.0.0)"/>
    <required namespace="org.eclipse.equinox.p2.iu" name="org.eclipse.ui" range="[3.108.0,4.0.0)"/>
    <required namespace="org.eclipse.equinox.p2.iu" name="org.eclipse.team.ui" range="[3.8.0,4.0.0)"/>
    <required namespace="org.eclipse.equinox.p2.iu" name="org.eclipse.jface.text" range="[3.11.0,4.0.0)"/>
    <required namespace="org.eclipse.equinox.p2.iu" name="org.eclipse.ui.ide" range="[3.12.0,4.0.0)"/>
    <required namespace="org.eclipse.equinox.p2.iu" name="org.eclipse.ui.workbench.texteditor" range="[3.10.0,4.0.0)"/>
    <required namespace="org.eclipse.equinox.p2.iu" name="org.eclipse.compare" range="[3.6.0,4.0.0)"/>

It seems to me that indeed the latest version EGit should install in anything older than Neon...
Re: egit plugin install fails [message #1815115 is a reply to message #1815038] Wed, 25 September 2019 15:23 Go to previous messageGo to next message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 161
Registered: August 2016
Senior Member
Ed Merks wrote on Tue, 24 September 2019 16:04
It seems to me that indeed the latest version EGit should install in anything older than Neon...


Typo? Did you mean "should not"? Or "newer"? I thought we had updated all minimum requirements to what was in Neon.0 a while ago.
Re: egit plugin install fails [message #1815116 is a reply to message #1815115] Wed, 25 September 2019 15:30 Go to previous messageGo to next message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 161
Registered: August 2016
Senior Member
IBM's own page on RSA 9.7 says they include EGit 4.1.1. Which is, even given the notoriously conservative policies IBM seems to have for updating for RSA, outright ridiculous. That's four year old version.
Re: egit plugin install fails [message #1815120 is a reply to message #1815116] Wed, 25 September 2019 16:23 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30551
Registered: July 2009
Senior Member
Yes, sorry, the "not" versus newer/older got screwed up.
Previous Topic:Gradle IDE installation fails
Next Topic:(PTP synchronized projects) Problems using multiple ssh accounts grouped together for teamwork
Goto Forum:
  


Current Time: Sun Oct 20 05:50:25 GMT 2019

Powered by FUDForum. Page generated in 0.03651 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top