Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Handler enable/disable not working
Handler enable/disable not working [message #1811337] Sat, 31 August 2019 14:59
Ludwig Moser is currently offline Ludwig MoserFriend
Messages: 466
Registered: July 2009
Senior Member
Hello,
my application contains multiple bundles

rcp - which contains general features
views - which implemens different views
view-extension - which implements further features for some views

in "views" i have a View, which creates a popup menu, which contains Handlers, that are defined in the same Bundle and/or in the "rcp" bundle.
some Handlers are defined in "view-extension" - commands are defined there and handlers are assigned the same way they are defined in "rcp"

when running the application, ALL commands are sowing up correctly in Eclipse
BUT: not all isEnabled() methods are called! Especially only the isEnabled() of Commands which are defined in view-extension are ignored.

how come? and how can i solve this?

NOTES:
i am using Eclipse 4.6 (basically an e3 Application with compatibility layer)
all Handlers extend extends DIHandler<E>; if i copy the code from view-extension to view everything works as expected (but Commands beeing in other bundles shall not be the problem, as its working with Handlers in "rcp" too)

sorry for double posting (https://www.eclipse.org/forums/index.php/m/1811330/#msg_1811330)
Previous Topic:How to change the language of Minimize/Maximize button in a PartStack?
Next Topic:How to get the part object out of a cloned snippet
Goto Forum:
  


Current Time: Thu Dec 12 18:33:49 GMT 2019

Powered by FUDForum. Page generated in 0.01378 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top