Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Need help building the eclipse platform runtime (platform.ui, .ua)
Need help building the eclipse platform runtime (platform.ui, .ua) [message #1811194] Wed, 28 August 2019 14:07 Go to next message
Simon L. is currently offline Simon L.Friend
Messages: 8
Registered: July 2009
Junior Member
I need to build org.eclipse.ui and org.eclipse.ua. I want to fix a bug there and I had some success building these projects from the command line with Maven. However, to do debugging work, I want to work on the code inside of Eclipse, and this is where I have problems where my previous experience with Eclipse does not serve much any more. I hope to get over these problems with your help. Let me quickly describe from which angle I am coming here:

For the JCrypTool project, we have a long-standing problem with Eclipse 3.x that prevents the help system (context help) from working correctly. Specifically, the context help (i.e. "F1" window) contains links to the TOC help that result in an error when clicked as opposed to opening the online help. We wish to fix this bug, and for this, we apparently need to debug and fix it in the projects eclipse.platform.ui and eclipse.platform.ua (where some internal classes reside).
Our issue is here: https://github.com/jcryptool/crypto/issues/153#issuecomment-517289295
Building it is one step, integrating the result into our existing project would be the next. I would go with selectively specifying the target platform of our product - all bundles as before (from the eclipse central repo) but the bundles that I fixed, which I would include from the local Maven build or self-hosted -- until such changes end up upstream (ideally). For that however, the first step would be to actually make the changes and I want to have a working Eclipse development environment for that which is where I got stuck:

What I did was:
- Set up a dedicated eclipse instance (Eclipse for RCP/RAP development 2019-06) and workspace
- Follow these steps https://wiki.eclipse.org/Platform/How_to_Contribute#.5B4.5D_Prepare_API_tooling until [4] API Tooling.
- I have used the integration build I20190812-1800 as API baseline and I have left the Target Platform set as "Running Platform"
- In that whole process, the "Team Project Set" http://git.eclipse.org/c/platform/eclipse.platform.ui.git/plain/releng/org.eclipse.ui.releng/platformUiProjectsGerrit.psf was imported and resulted in these repositories being cloned and imported into the workspace:

  • eclipse.platform.releng
  • eclipse.platform.runtime
  • eclipse.platform.ui (which I want to develop on, and also, later, on eclipse.platform.ua)


Now, much of it looks good. However, some packages cannot be resolved and I am at loss here on how to fix this. In between I went ahead and imported all projects from the repositories that had not been imported during the "Team Project Set" import process, and some errors disappeared. Now, primarily, these packages are the issue:
- org.eclipse.swt.internal.cocoa
- org.eclipse.swt.ole

The attached screenshot shows some of the errors that are at the receiving end of those packages missing.

I have then tried to also import into my workspace a clone of the org.eclipse.swt project in the hope to get the missing dependencies there. However, to no avail: a lot of compilation errors pop up, including weird project structure issues (packages not declared in the correct source path). From here, I do not know how to continue.

Any help is much appreciated. I also wish to learn in that process about the platform, so enlighten me about obscure details or problems with my approach if you feel like it ;) Thanks!

[Updated on: Wed, 28 August 2019 14:24]

Report message to a moderator

Re: Need help building the eclipse platform runtime (platform.ui, .ua) [message #1811196 is a reply to message #1811194] Wed, 28 August 2019 14:25 Go to previous messageGo to next message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 135
Registered: April 2012
Senior Member
Having issues on o.e.s.i.cocoa and on o.e.s.ole indicates that something is wrong with your OS configuration. Projects for both Mac and Windows are included.

Personally, I always use the Oomph setups to install the Eclipse development environment. This completely automates all the steps you have to take and results in a correct environment, https://wiki.eclipse.org/Platform_UI/How_to_Contribute/Oomph.
Re: Need help building the eclipse platform runtime (platform.ui, .ua) [message #1811199 is a reply to message #1811196] Wed, 28 August 2019 14:52 Go to previous messageGo to next message
Simon L. is currently offline Simon L.Friend
Messages: 8
Registered: July 2009
Junior Member
Thanks for your answer. I will try the Oomph but have no idea what the config is I will have to ask it to set up. I have used it already to install the RCP 2019-06 eclipse which hosts my workspace, but that was basic mode.

- Should I use it also to download the API baseline instead of downloading the I-Build and using that? If so, how?
- Are there recommended configuration steps to take within Oomph? There is little configuration to be done in "basic mode" (were I selected the RCP development edition) but a massive amount of choices in advanced mode.

I am under Ubuntu 18.10 by the way, so neither OSX nor Windows packages will help me, unfortunately. I would consider to switch to Windows, but not if it is not strictly necessary to do so.

[Updated on: Wed, 28 August 2019 14:54]

Report message to a moderator

Re: Need help building the eclipse platform runtime (platform.ui, .ua) [message #1811201 is a reply to message #1811199] Wed, 28 August 2019 15:12 Go to previous messageGo to next message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 135
Registered: April 2012
Senior Member
An extra dot was added to the link [1], it should explain all you need. Select a recent product version (Latest), select the UI and UA projects, it will automatically select the correct baseline.
If you want to use the latest nightly builds for developing, use the setup as described in [2], no need to select all the platform projects though.

[1] https://wiki.eclipse.org/Platform_UI/How_to_Contribute/Oomph
[2] https://wiki.eclipse.org/Eclipse_Platform_SDK_Provisioning
Re: Need help building the eclipse platform runtime (platform.ui, .ua) [message #1811291 is a reply to message #1811201] Fri, 30 August 2019 07:29 Go to previous messageGo to next message
Simon L. is currently offline Simon L.Friend
Messages: 8
Registered: July 2009
Junior Member
Thanks! I have still problems though but at least not the same ones :) I will get deeper into this come next week, hope to continue here then!
Re: Need help building the eclipse platform runtime (platform.ui, .ua) [message #1816286 is a reply to message #1811201] Fri, 25 October 2019 12:36 Go to previous message
Simon L. is currently offline Simon L.Friend
Messages: 8
Registered: July 2009
Junior Member
Problem solved for the original question! New problems arise of course. I'd appreciate of course if someone looked at them: https://www.eclipse.org/forums/index.php/t/1101081/

For the time being, thanks, Rolf!

[Updated on: Wed, 30 October 2019 09:27]

Report message to a moderator

Previous Topic:Proxy / SSL problems with update sites
Next Topic:Need help building org.eclipse.ua without having to build every other eclipse project
Goto Forum:
  


Current Time: Thu Jul 09 08:51:27 GMT 2020

Powered by FUDForum. Page generated in 0.02691 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top