Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Oomph failure(Oomph cannot find Java on Ubuntu)
Oomph failure [message #1810979] Thu, 22 August 2019 23:06 Go to next message
Jonathan Gossage is currently offline Jonathan GossageFriend
Messages: 69
Registered: March 2010
Location: Ottawa, ON, Canada
Member
I am running Ubuntu 18.04.3 and I am attempting to install Eclipse. I downloaded and extracted the installer but when I attempted to run it Oomph stated that it could not find Java.

Oracle Java 12.0.2 is installed and both the PATH and JAVA_HOME have been set.
When I do
java -version
it gives me the following output:

j
ava version "12.0.2" 2019-07-16
Java(TM) SE Runtime Environment (build 12.0.2+10)
Java HotSpot(TM) 64-Bit Server VM (build 12.0.2+10, mixed mode, sharing
)

What could I be doing wrong?
Re: Oomph failure [message #1810987 is a reply to message #1810979] Fri, 23 August 2019 03:58 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30452
Registered: July 2009
Senior Member
You're using the installer you got from here:

https://www.eclipse.org/downloads/

And you're running it from this same shell where this PATH is set up properly?

As an alternative you can download a package from here:

https://www.eclipse.org/downloads/packages/

But the native executable is the same one as used by the installer, so running it will likely suffer the same problem...

Re: Oomph failure [message #1810990 is a reply to message #1810987] Fri, 23 August 2019 05:28 Go to previous messageGo to next message
Jonathan Gossage is currently offline Jonathan GossageFriend
Messages: 69
Registered: March 2010
Location: Ottawa, ON, Canada
Member
I am using a different shell but I have set the appropriate settings in .bashrc so I should have the same environment. I have verified that the changes to .bashrc do work. I intend to see if using Java 11 gives the same problem.
Re: Oomph failure [message #1810998 is a reply to message #1810990] Fri, 23 August 2019 08:54 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30452
Registered: July 2009
Senior Member
Java 8 is likely to work best, but I have tested (on Windows) that the (latest) installer runs with Java 12...
Previous Topic:Log File for installation Error
Next Topic:How to use empty redirectable catalogs for projects
Goto Forum:
  


Current Time: Fri Sep 20 06:06:24 GMT 2019

Powered by FUDForum. Page generated in 0.01880 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top