Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Breakpoints stop working with JUnits/Mockito mid-development(Running JUnit tests, eventually breakpoints stop breaking or going to the debugger)
Breakpoints stop working with JUnits/Mockito mid-development [message #1810896] Wed, 21 August 2019 12:49 Go to next message
J Smith is currently offline J SmithFriend
Messages: 1
Registered: August 2019
Junior Member
I've been using Eclipse for decades, and sure, after using an install for a while stuff eventually stops working correctly. But this install is less than 4 months old.

I'm running JUnit tests (and sometimes Cucumber tests hooked in) with the debug icon in the toolbar. They've worked until yesterday.

I started using Mockito spy(..) because one class is too complex and started getting the "Unable to install breakpoint in...$MockitoMock$.. due to missing line number attributes. Modify compiler options.."

But then it continued running, showed the message a couple more times, and finally went to the debugger.

Well, all those pop-ups are annoying, but after clicking "Don't show this message again" on the dialog, the Debugger perspective never comes up again. Even in a new workspace.

Let me say that again: now the debugger never appears and execution never stops. "Debug" is working exactly like "Run".

I've:
A) gone into the debugger Perspective and tried deleting all breakpoints and creating new ones.
B) gone to the breakpoint pane, right-clicked, and tried removing all triggers - there are none
C) after running the project as a JUnit stopped debugging, I tried debugging the file itself - same failure.
D) restarted the Eclipse
E) restarted the laptop
F) created a new workspace for the git project - both created/downloaded in new disk locations.
G) Preferences > Java > Compiler, "Add line number attributes..." is still checked.

No change in getting the debugger to appear during execution.

Oddly, after creating the new workspace that pop-up error only appears once when debugging the tests, but it should hit that breakpoint twice from different tests methods, like it did before it stopped working...


This is STS4/Eclipse Platform 4.11.0.v20190307-0500 running on Windows 10.

So who can tell me: what is the secret setting which got corrupted?

Or is a re-install/nuke the HD from orbit the only possible solution?

Thanks!
Re: Breakpoints stop working with JUnits/Mockito mid-development [message #1810971 is a reply to message #1810896] Thu, 22 August 2019 18:12 Go to previous messageGo to next message
Sarika Sinha is currently offline Sarika SinhaFriend
Messages: 114
Registered: February 2010
Location: Bangalore, India
Senior Member
All these preferences related to Debug perspective to show the dialogs are defined under Preferences->Run/Debug or Preferences->Java->Debug

You will say many "Prompt for.." preferences defined there, you can enable them again.


Sarika Sinha
JDT Programmer
Re: Breakpoints stop working with JUnits/Mockito mid-development [message #1828038 is a reply to message #1810971] Fri, 29 May 2020 18:35 Go to previous message
Puneet Bhalla is currently offline Puneet BhallaFriend
Messages: 1
Registered: May 2020
Junior Member
Hi there,
I'm facing the same problem, has anyone managed to figure out the solution for this issue yet?? any help would be much appreciated

Thanks
Previous Topic:Eclipse Not visible to other users on Machine
Next Topic:JDT compiler
Goto Forum:
  


Current Time: Mon Oct 19 22:32:48 GMT 2020

Powered by FUDForum. Page generated in 0.06814 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top