Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » NatTable » SelectAll does not select all rows [solved]
SelectAll does not select all rows [solved] [message #1810102] Wed, 31 July 2019 07:24
Klaus Reger is currently offline Klaus RegerFriend
Messages: 10
Registered: December 2016
Junior Member
Sometimes not all records are selected when pressing the Ctrl-A key combination. Although all rows are optically marked as selected, when the selection is requested programmatically, the set contains one or two fewer data records. However, the behavior cannot be reliably reproduced.

Example:

In the RowSelectionModel, the row is returned:
int maxY = Math.min(range.y + range.height, this.selectionLayer.getRowCount());


the value 30002

but a few lines later the expression
rowsToSelect.size() 
(int) 30001


Solution:
The problem was raised by a hash collision of two of the data rows

[Updated on: Wed, 31 July 2019 09:09]

Report message to a moderator

Previous Topic:How to get notified, that the DataLayer has finished loading data
Next Topic:Changing Font type of NatTable header dynamically
Goto Forum:
  


Current Time: Tue Jun 22 15:18:24 GMT 2021

Powered by FUDForum. Page generated in 0.02176 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top