Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Moka: "Your first executable model" leads to nullpointer exception(trying to get started with Moka, but failed by nullpointer exception)
Moka: "Your first executable model" leads to nullpointer exception [message #1809182] Wed, 10 July 2019 17:52 Go to next message
Rolf Schumacher is currently offline Rolf SchumacherFriend
Messages: 56
Registered: January 2014
Member
I tried to get started with Moka, installed it to Eclipse 2019-06 from the update sites mentioned in Getting started with Moka. Downloaded File:BasicActiveObjectExample.zip, set a breakpoint and run in Debug. It led to Nullpointer exception.

It did not help to install everything fresh: eclipse modelling 2019-06, Papyrus from update-site, Moka by moving the Install button to the workspace. The nullpointer exception remains after start debugging. Is the example BasicActiveObjectExample compatible with these versions?

Should it work as described here?
Re: Moka: "Your first executable model" leads to nullpointer exception [message #1809258 is a reply to message #1809182] Fri, 12 July 2019 13:54 Go to previous messageGo to next message
Pauline Deville is currently offline Pauline DevilleFriend
Messages: 42
Registered: November 2016
Location: Paris Saclay, France
Member
Hello,

How did you install moka, since I saw that the "Getting started with Moka" was not up to date I just update the update site and installation guide lines: https://wiki.eclipse.org/Papyrus/UserGuide/ModelExecution#Moka_Releases. To be on the best install to use Moka you should better use an eclipse 2019-03 version since this is the last version of Moka.

With this install I think that it should works if you create the factory as explain Your first executable model and you setup the launch configuration as explain in in Starting an execution with a launch configuration. We note that some part of this tutorial are not update anymore.

Which engine did you set in the launch configuration ? May be you should try org.eclipse.papyrus.moka.timedfuml.

HTH,
Best regards,
Pauline
Re: Moka: "Your first executable model" leads to nullpointer exception [message #1809352 is a reply to message #1809258] Sat, 13 July 2019 20:05 Go to previous messageGo to next message
Rolf Schumacher is currently offline Rolf SchumacherFriend
Messages: 56
Registered: January 2014
Member
Hi, Pauline
I tried several versions: 2019-06 with nightly, downloaded papyrus-2019-06-4.4.0 with moka installed from nightly, strictly modeling 2019-03 with moka installed from 4.0.0 update site, changed eclipse.ini to Java 1.8, it is always the same: Debugging starts with animation until "Set counter" is highlighted, then the null-pointer exception pops up.

I attached a short video to show what I experienced.

Any idea what to do next?

Rolf
Re: Moka: "Your first executable model" leads to nullpointer exception [message #1809383 is a reply to message #1809352] Mon, 15 July 2019 09:59 Go to previous messageGo to next message
Pauline Deville is currently offline Pauline DevilleFriend
Messages: 42
Registered: November 2016
Location: Paris Saclay, France
Member
Hi Rolf,

If the execution appear when the set counter is trigger, an explanation could be that the "Increment" instance is not initialize then the counter property equals "null". Are you sure you reference the factory into the Launch configuration and not the IncrementClassifierBehavior (see attach picture)? The goal of the factory is to create The Increment instance and initialize its property then call the ClassifierBhavior.

HTH,
Pauline

Re: Moka: "Your first executable model" leads to nullpointer exception [message #1809687 is a reply to message #1809383] Sat, 20 July 2019 09:55 Go to previous message
Rolf Schumacher is currently offline Rolf SchumacherFriend
Messages: 56
Registered: January 2014
Member
Thank you Pauline - that was the fault to be found. It works now a expected.
Previous Topic:Stereotype just for on property in class diagram
Next Topic:Moka Debug Resume Button greyed out
Goto Forum:
  


Current Time: Mon Dec 16 01:44:27 GMT 2019

Powered by FUDForum. Page generated in 0.03452 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top