Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » P2 Director dependency at recent version(P2 Director dependency at recent version)
P2 Director dependency at recent version [message #1808538] Wed, 26 June 2019 12:40 Go to next message
Pit Friedrich is currently offline Pit FriedrichFriend
Messages: 2
Registered: June 2019
Junior Member
Hello!

In an Oomph setup configuration I am able to add dependencies to a P2 Director. Is it possible for a P2 Director dependency to be always the recent version? I'm only able to set a version range. But when the installed dependency is in that range it counts as fulfilled. But I want it to be the most recent version. Is that possible?

Thank you
Re: P2 Director dependency at recent version [message #1808571 is a reply to message #1808538] Thu, 27 June 2019 02:35 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30448
Registered: July 2009
Senior Member
No, in the absence of version range restrictions, p2 will generally install the latest available version and you control what's available via the repositories that you specify. So if you should focus on specifying a repository with the most recent version. For example, EMF provides the repository https://download.eclipse.org/modeling/emf/emf/builds/release/latest which always composes the latest released version of EMF. After all, even if you could specify somehow the most recent version, you'd still have to make sure it's available in one of the repositories you specify. If p2 doesn't install the latest version automatically it's most likely because something else you've installed or are installing requires (restricts) to an older version range.
Re: P2 Director dependency at recent version [message #1808631 is a reply to message #1808571] Fri, 28 June 2019 05:13 Go to previous messageGo to next message
Pit Friedrich is currently offline Pit FriedrichFriend
Messages: 2
Registered: June 2019
Junior Member
Thank you for your answer. But when I add the p2 repository url in the "Install New Software" dialog, it apprently "knows" what feature has a newer version. I was just wondering...
Re: P2 Director dependency at recent version [message #1808640 is a reply to message #1808631] Fri, 28 June 2019 06:11 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30448
Registered: July 2009
Senior Member
Yes, at that point it's loaded the repository and of course can show you information specific to the loaded repository. In this dialog there is a checkbox "Show only the latest versions of available software" so of course with that checked, you see the latest and you will install exactly the version that you choose, necessarily the latest if those are the only ones you are displaying.

Do you have some reason to be concerned that for some random reason an older version will be installed instead of the latest from among all the available versions? It is my experience that when I run (or rerun) the p2 director task, if there are updates (newer versions) available for of any of the required IUs, they will be installed, without me needing to specify that in some way.
Previous Topic:There's something wrong with my Eclipse installing
Next Topic:Probably dumb question: How do I determine p2 url for plugin from marketplace?
Goto Forum:
  


Current Time: Tue Sep 17 16:25:45 GMT 2019

Powered by FUDForum. Page generated in 0.01576 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top