Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » RAP compatible for the older version(RAP compatible for the older version 1.3)
RAP compatible for the older version [message #1808505] Tue, 25 June 2019 23:59 Go to next message
Josh Mo is currently offline Josh MoFriend
Messages: 2
Registered: June 2019
Junior Member
I am using the old version of RAP (version 1.3). Is the new version (version 3.9) compatible for the old version, so that I don't need to make any changes to my code?
Re: RAP compatible for the older version [message #1808520 is a reply to message #1808505] Wed, 26 June 2019 08:40 Go to previous message
Markus Knauer is currently offline Markus KnauerFriend
Messages: 152
Registered: July 2009
Senior Member

Hi Josh,

RAP 1.3 is very old... June 2010. Amazing that your application is still working with the modern browsers of today.

We are following the semantic versioning guidelines, and therefore there are quite some incompatibilities to be expected. For the migration to 2.x and to 3.x we've prepared some migration guides that are highlighting the most important changes:

- 2.0 migration guide: https://www.eclipse.org/rap/noteworthy/2.0/migration-guide/
- 3.0 migration guide: https://www.eclipse.org/rap/noteworthy/3.0/migration-guide/

Regards,
Markus


--

Twitter: @mknauer23 and @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Previous Topic:RAP 3.7 and Java 11 Support
Next Topic:Has Eclipse RAP stopped developing?
Goto Forum:
  


Current Time: Mon Dec 16 10:16:22 GMT 2019

Powered by FUDForum. Page generated in 0.01256 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top