Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » Cannot install experimental features of Sirius 6.2.0 in Photon
Cannot install experimental features of Sirius 6.2.0 in Photon [message #1808178] Tue, 18 June 2019 15:26 Go to next message
Rakesh Nidavani is currently offline Rakesh NidavaniFriend
Messages: 21
Registered: March 2018
Junior Member
Hello,

I have downloaded Eclipse phton and Sirius 6.2.0(photon compatible ).

I am not able to install experimental feature such as server and workflow.

Below is the dependency error message which i am getting.

Missing requirement: Sirius Server 6.2.0.201903051604 (org.eclipse.sirius.server 6.2.0.201903051604) requires 'osgi.bundle; javax.websocket 1.0.0' but it could not be found
Cannot satisfy dependency:
From: Sirius Server (Experimental) 6.2.0.201903051604 (org.eclipse.sirius.server.feature.feature.group 6.2.0.201903051604)
To: org.eclipse.equinox.p2.iu; org.eclipse.sirius.server [6.2.0.201903051604,6.2.0.201903051604]
Cannot satisfy dependency:
From: Sirius Server Auto Start (Experimental) 6.2.0.201903051604 (org.eclipse.sirius.server.ui.autostart.feature.feature.group 6.2.0.201903051604)
To: org.eclipse.equinox.p2.iu; org.eclipse.sirius.server.feature.feature.group 0.0.0


Can you please assist me on this. Please find attached screenshot of the issue.

Regards,
Rakesh
Re: Cannot install experimental features of Sirius 6.2.0 in Photon [message #1808196 is a reply to message #1808178] Wed, 19 June 2019 06:16 Go to previous messageGo to next message
Pierre-Charles David is currently offline Pierre-Charles DavidFriend
Messages: 486
Registered: July 2009
Senior Member
Hi,

This part of the experimental Sirius Server depends on a particular version of javax.websocket (and javax.servlet) which are not directly available in the main Eclipse Photon repo. We do not include them either in our own repository to reduce the risks of conflicts with other versions.

You can get them from the Orbit repository at http://download.eclipse.org/tools/orbit/downloads/drops/R20181128170323/repository, which is the one we reference when we build Sirius 6.2 itself. If you are installing directly from Eclipse (as opposed to during a Maven/Tycho build), simply add that Orbit repo to the list of available update sites (Window > Preferences > Install/Update > Available Software Site), and the retry installing the Sirius feature (make sure the "Contact all update sites" checkbox is enabled). Eclipse should then be able to find the required dependencies.

Regards,
Pierre-Charles David


Pierre-Charles David - Obeo

Need training or professional services for Sirius?
http://www.obeodesigner.com/sirius
Re: Cannot install experimental features of Sirius 6.2.0 in Photon [message #1808480 is a reply to message #1808196] Tue, 25 June 2019 13:43 Go to previous message
Rakesh Nidavani is currently offline Rakesh NidavaniFriend
Messages: 21
Registered: March 2018
Junior Member
Hello,

Thank you I am able to install workflow features now.

I am able to configure the workflow pages but not getting how to configure this feature on server.

Can you please assist me on this ?

Regards,
Rakesh

Previous Topic:[ANN] Sirius 6.2.1
Next Topic:Opening sirius session
Goto Forum:
  


Current Time: Thu Aug 22 06:45:47 GMT 2019

Powered by FUDForum. Page generated in 0.02088 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top