Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Persian characters showed separately in PDF generated using BIRT
Persian characters showed separately in PDF generated using BIRT [message #1808085] Mon, 17 June 2019 10:21
Nader Abbasi is currently offline Nader AbbasiFriend
Messages: 2
Registered: June 2019
Junior Member
I've developed a report using the BIRT Report Designer RCP 4.8.0. I've built a report contains some Persian (or Farsi) texts. The designer show my Persian texts correctly, but when I rendered the report in PDF format, some Persian characters are incorrect. The generated PDF file doesn't show special Persian characters which are not same as Arabic characters. There are some common characters in Arabic and Persian which has different shapes in two languages and also Persian has 4 more characters than Arabic. When I see the report in PDF format some characters showed separated. Also I apply some settings to fontsConfig.xml file and these fonts apply to the generated PDF file, but as I mentioned there are a problem with some special Persian characters that doesn't exist in Arabic.

How can I fix this problem?
Previous Topic:Data Source property binding using fields from data set
Next Topic:Persian characters showed separately in PDF generated using BIRT
Goto Forum:
  


Current Time: Sat Oct 19 16:52:45 GMT 2019

Powered by FUDForum. Page generated in 0.01586 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top