Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » RAP starting issue with 2019-06 RC1
RAP starting issue with 2019-06 RC1 [message #1807907] Wed, 12 June 2019 07:57 Go to next message
Arnaud MERGEY is currently offline Arnaud MERGEYFriend
Messages: 235
Registered: March 2010
Location: France
Senior Member
Hello,

Trying to upgrade my target platform to RAP 2019-06, my RAP application cannot start anymore with following exception

java.lang.NullPointerException
at org.eclipse.rap.ui.internal.servlet.WorkbenchApplicationConfiguration.getOSGiProperty(WorkbenchApplicationConfiguration.java:147)
at org.eclipse.rap.ui.internal.servlet.WorkbenchApplicationConfiguration.registerSettingStoreFactory(WorkbenchApplicationConfiguration.java:107)
at org.eclipse.rap.ui.internal.servlet.WorkbenchApplicationConfiguration.configure(WorkbenchApplicationConfiguration.java:94)
at org.eclipse.rap.rwt.internal.application.ApplicationContextImpl.doActivate(ApplicationContextImpl.java:371)
at org.eclipse.rap.rwt.internal.application.ApplicationContextImpl.activate(ApplicationContextImpl.java:244)
at org.eclipse.rap.rwt.application.ApplicationRunner.start(ApplicationRunner.java:79)

Revert back to 2018-12 works

I saw someone having the same in rap-dev mailing list trying to start rap demo, is it a known issue ?

Arnaud

[Updated on: Wed, 12 June 2019 07:58]

Report message to a moderator

Re: RAP starting issue with 2019-06 RC1 [message #1807909 is a reply to message #1807907] Wed, 12 June 2019 08:08 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2327
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi,

that's fixed in the latest nightly and will be fixed in 3.9RC2 too.

Best regards,
Ivan
Re: RAP starting issue with 2019-06 RC1 [message #1807910 is a reply to message #1807907] Wed, 12 June 2019 08:10 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2327
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
... just for the record. This is the RAP bug:

547895: NPE WorkbenchApplicationConfiguration#getOSGiProperty
https://bugs.eclipse.org/bugs/show_bug.cgi?id=547895

and this is the bug I opened against the platform:

548137: Platform.getBundle( Constants.SYSTEM_BUNDLE_SYMBOLICNAME ) returns null
https://bugs.eclipse.org/bugs/show_bug.cgi?id=548137
Re: RAP starting issue with 2019-06 RC1 [message #1807915 is a reply to message #1807910] Wed, 12 June 2019 08:26 Go to previous message
Arnaud MERGEY is currently offline Arnaud MERGEYFriend
Messages: 235
Registered: March 2010
Location: France
Senior Member
ok thanks Ivan
Previous Topic:Theme of comboxbox
Next Topic:A large number of members and online users
Goto Forum:
  


Current Time: Tue Dec 10 11:20:46 GMT 2019

Powered by FUDForum. Page generated in 0.02034 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top