Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Compiler compliance in limited to Java 8?
Compiler compliance in limited to Java 8? [message #1807372] Tue, 28 May 2019 17:46
Glenn Burkhardt is currently offline Glenn BurkhardtFriend
Messages: 9
Registered: April 2017
Junior Member
For a headless build, I've tried setting 'javacSource' and 'javacTarget' to 1.9 and 1.11, but these values apparently are not recognized properly, because the build fails with errors that indicate the Java compliance level is set to the the default 1.3, e.g.,

Syntax error, parameterized types are only available if source level is 1.5 or greater

Using the value 1.8 works. Am I wrong in thinking that this is a bug in Eclipse 4.11? Or do I have the naming convention wrong for the Java version. I'm trying to build with Java 11.
Previous Topic:Exporting product
Next Topic:NPE in ColumnViewerEditor due to cellEditor is null
Goto Forum:

Current Time: Sat Jan 28 11:38:56 GMT 2023

Powered by FUDForum. Page generated in 0.04582 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top