Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » QVT-OML » Could not find unit 'platform:/resource(QVTO Transformation)
Could not find unit 'platform:/resource [message #1805700] Mon, 22 April 2019 07:28 Go to next message
Ranjith S Nair is currently offline Ranjith S NairFriend
Messages: 3
Registered: January 2019
Junior Member
Hi Team,

I am building an eclipse plugin that will transform my metamodel to RDS metamodel. But I am getting below exception.

Diagnostic ERROR source=org.eclipse.m2m.qvt.oml.execution code=200: Could not find unit 'platform:/resource/sql.metamodel.qvto/transforms/SealToSql.qvto'

It started after converting the project to Maven
When I create a new QVTO plugin project i am getting qvto file as file:/.... but when i convert the project to maven nothing is working.

I tried both standalone and running from eclipse instance, my requirement is running from eclipse instance.

I have attached the plugin.xml file also i want to transform SealToSql.qvto file from my acceleo project

Sample code is attached.
Re: Could not find unit 'platform:/resource [message #1805701 is a reply to message #1805700] Mon, 22 April 2019 08:36 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6481
Registered: July 2009
Senior Member
Hi

"Maven". Sorry, there is no way I am going to look at anything that does not come with a complete project repro and M2E launch configuration.

My very strong suspicion is that the file paths under Maven are different and consequently files are not consistently resolved. Combined use of "file:" and "plugin" is not usually a good idea. You should be able to debug it by ensuring that your application works as a conventional standalone application, then debugging why the files names are inconsistent in your Maven variant. It may be as simple as ensuring that your default working directory is right .... But when I migrated all the OCL, QVTd JUnit tests from Buckminster to Tycho, I had to rewrite all usage of temporary files since under Buckminster testing occurred pre-packaging allowing the pre-packaged files to mutate. Ouch! Tycho tests post-packaging so storing temporaries in plugins fails. All temporaries had to be moved into new auto-generated workspace projects. You might need to do the same to respect the integrity of Maven/Tycho. Trying to make the target/... directory tree work as part of the Eclipse platform:/... virtual tree may be too hard and fundamentally unsound.

Regards

Ed Willink
Re: Could not find unit 'platform:/resource [message #1805738 is a reply to message #1805701] Tue, 23 April 2019 02:24 Go to previous messageGo to next message
Ranjith S Nair is currently offline Ranjith S NairFriend
Messages: 3
Registered: January 2019
Junior Member
Sorry I am not understanding anything. Why eclipse is not identifying the QVTO file unit ? How to see the exact issue ? The problem here is I have one acceleo project and a QVTO java plugin, The QVTO project is added as dependency. but still I am not able to call the QVTO file using platform URI. Somehow it is now working fine in standalone mode but when i running it from eclipse instance i am getting error.
Re: Could not find unit 'platform:/resource [message #1805749 is a reply to message #1805738] Tue, 23 April 2019 07:22 Go to previous message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6481
Registered: July 2009
Senior Member
Ranjith S Nair wrote on Mon, 22 April 2019 22:24
Sorry I am not understanding anything..


I wrote:
Quote:
"Maven". Sorry, there is no way I am going to look at anything that does not come with a complete project repro and M2E launch configuration.


See e.g. https://wiki.eclipse.org/OCL/ForumNetiquette

Regards

Ed Willink
Previous Topic:Announce QVTo 3.9.2
Next Topic:Executing query standalone mode and retrieve results
Goto Forum:
  


Current Time: Tue Oct 15 22:31:05 GMT 2019

Powered by FUDForum. Page generated in 0.01641 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top