Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » RAP-Application on Glassfish(RAP-Application on Glassfish-Server)
RAP-Application on Glassfish [message #1804465] Tue, 26 March 2019 12:16 Go to next message
Markus Sundermann is currently offline Markus SundermannFriend
Messages: 3
Registered: March 2019
Junior Member
Hello guys,
I'm very new to the topics RAP and RCP. My task is it to implement a RAP-Application which should run on a Glassfish server 4.0.
My problem is that it doesn't run on the glassfish. I created a new plug-in project with the rap e4 demo. In eclipse the application runs. Then I tried to convert it to a maven project and deploy it on glassfish. But I always get an error message.

Thanks for your help,
Markus
Re: RAP-Application on Glassfish [message #1804505 is a reply to message #1804465] Wed, 27 March 2019 14:17 Go to previous messageGo to next message
Markus Sundermann is currently offline Markus SundermannFriend
Messages: 3
Registered: March 2019
Junior Member
Can anyone tell me if it's possible to run a RAP-Application on Glassfish?
Re: RAP-Application on Glassfish [message #1804515 is a reply to message #1804505] Wed, 27 March 2019 19:28 Go to previous messageGo to next message
Chris Fairhall is currently offline Chris FairhallFriend
Messages: 221
Registered: February 2011
Senior Member
I don't see why not. I've had no problems with JBoss AS, Tomcat and Wildfly
You've provide almost no information about your specific problem, so I don't know how anyone can be expected to help you.
Re: RAP-Application on Glassfish [message #1804520 is a reply to message #1804515] Thu, 28 March 2019 07:00 Go to previous messageGo to next message
Markus Sundermann is currently offline Markus SundermannFriend
Messages: 3
Registered: March 2019
Junior Member
Hey,
thank you for the answer.

I use the Eclipse ID for RCP (Version: 2019-03 (4.11.0) Build id: 20190314-1200) and RAP-Developers and the GlassFish Server Open Source Edition 4.0 (build 89).
I've tried it with the WAR Product Configuration and with this guide :

https://help.eclipse.org/2019-03/index.jsp?topic=%2Forg.eclipse.rap.doc%2Fguide%2Farticles%2Fdeployment.html

Then I deployed the war-archive on GlassFish and launched. The error message I've got is:


HTTP Status 404 - BridgeServlet: /rapdemo/workbench/ type
Status report messageBridgeServlet: /rapdemo/workbench/ description
The requested resource is not available. GlassFish Server Open Source Edition 4.0


In the Log of the Glassfish I get a lot of "ArrayIndexOutOfBoundsException"-Exceptions.

Thanks for the help!

[Updated on: Thu, 28 March 2019 07:38]

Report message to a moderator

Re: RAP-Application on Glassfish [message #1804792 is a reply to message #1804520] Mon, 01 April 2019 10:52 Go to previous message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2327
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi,
which RAP version are you using. We discovered a problem in Equinox that prevents RAP applications built on RAP 3.8 to start on servlet container based on Servlet 3.1 Spec [1]. There is a workaround of the problem to manually create and add to the war file "org.eclipse.equinox.servletbridge.extensionbundle" bundle that re-exports "javax.sevlet" as 3.1.

[1] 545682: org.eclipse.equinox.http.servlet and org.eclipse.equinox.servletbridge do not work together anymore in Tomcat 8.5.x
https://bugs.eclipse.org/bugs/show_bug.cgi?id=545682

Best regards,
Ivan

[Updated on: Wed, 03 April 2019 08:31]

Report message to a moderator

Previous Topic:@ProcessAdditions @EventTopic
Next Topic:composite or canvas to image or imagedata
Goto Forum:
  


Current Time: Mon Dec 16 10:22:30 GMT 2019

Powered by FUDForum. Page generated in 0.02452 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top