Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » build os image for wago pfc100 series PLC
build os image for wago pfc100 series PLC [message #1804204] Wed, 20 March 2019 10:54 Go to next message
sudeesh vs is currently offline sudeesh vsFriend
Messages: 4
Registered: March 2019
Junior Member
Hello
iam sudeesh v s, currently i am try to build os image for wago pfc100 series PLC with FORTE. iam following the step described in " https://www.eclipse.org/4diac/en_help.php?helppage=html/installation/wago.html" and "HowTo_Install_WAGO-PFC-BSP-2018.8.27.txt" file in WAGO-PFC-BSP-2018.08.27-2.8.35 .Please find an attachment screen-shot. I think this could be the root cause of my issue.

It seem that when run " sudo ptxdist targetinstall forte_wago
" commands error ,i try this one "ptxdist go -q" but no change .



-/home/user/wago2/ptxproj-2.8.35/platform-wago-pfcXXX/build-host/pkg-config-0.25/glib-1.2.10/glib.h:1616: multiple definition of `g_bit_storage'
testglib.o:/home/user/wago2/ptxproj-2.8.35/platform-wago-pfcXXX/build-host/pkg-config-0.25/glib-1.2.10/glib.h:1616: first defined here
collect2: error: ld returned 1 exit status
collect2: error: ld returned 1 exit status
make[5]: *** [testgdate] Error 1
make[5]: *** Waiting for unfinished jobs....
make[5]: *** [testgdateparser] Error 1
collect2: error: ld returned 1 exit status
make[5]: *** [testglib] Error 1
make[4]: *** [all-recursive] Error 1
make[3]: *** [all] Error 2
make[2]: *** [all-recursive] Error 1
make[1]: *** [all] Error 2
make: *** [/home/user/wago2/ptxproj-2.8.35/platform-wago-pfcXXX/state/host-pkg-config.compile] Error 2


Thanks for help
Best Regards
Re: build os image for wago pfc100 series PLC [message #1804268 is a reply to message #1804204] Thu, 21 March 2019 15:02 Go to previous messageGo to next message
Milan Vathoopan is currently offline Milan VathoopanFriend
Messages: 43
Registered: August 2016
Member
Hi Sudeesh,

Are you facing a problem in building ptxdist itself or forte? in which stage are you? You can start building forte only after ptxdist itself is built. Once ptxdist is built, you may use ptxdist as the build environment for building cross compiled applications for your Wago PFCs.

Please follow the help file "HowTo_Install_WAGO-PFC-BSP-2018.8.27.txt" and take care about the dependencies!

Also please note: You do not need root privilege for executing ptxdist commands

Milan
build os image for wago pfc100 series PLC [message #1804303 is a reply to message #1804268] Fri, 22 March 2019 06:08 Go to previous messageGo to next message
sudeesh vs is currently offline sudeesh vsFriend
Messages: 4
Registered: March 2019
Junior Member
Hello Milan,

Thanks a lot for your time and support.

As you recommended, i tried the steps in "How To_Install_WAGO-PFC-BSP-2018.8.27.txt" that worked well after that build. i installed " ptxdist targetinstall forte_wago" and building a image is success.

Please have a look at the screen shots as an attachment for verification of final output .

Thanks for help
Best Regards
Re: build os image for wago pfc100 series PLC [message #1804382 is a reply to message #1804303] Mon, 25 March 2019 09:25 Go to previous message
Milan Vathoopan is currently offline Milan VathoopanFriend
Messages: 43
Registered: August 2016
Member
Hi Sudeesh,

You are welcome and happy to know it is working. Looking forward to your experience with Eclipse 4diac and Wago PFC.

Milan
Previous Topic:Building FORTE with open62541
Next Topic:Issues while defining Internal Variable By "VAR "
Goto Forum:
  


Current Time: Fri Nov 15 15:13:54 GMT 2019

Powered by FUDForum. Page generated in 0.02410 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top