Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Titan » The version of the compiler could not be determined(I have given the path of compiler in titan preferences C/cygwin/home/A/ install still it id showing that the path of the compiler could be deternined )
The version of the compiler could not be determined [message #1802645] Wed, 13 February 2019 09:15 Go to next message
Reepandeep  Kaur is currently offline Reepandeep KaurFriend
Messages: 7
Registered: January 2019
Junior Member
I have given the path of compiler in titan preferences C/cygwin/home/A/ install

showing the error as Version of the compiler could not be derermined

Aslo i have followed the steps in the installation
Requesting for your reply
Re: The version of the compiler could not be determined [message #1802658 is a reply to message #1802645] Wed, 13 February 2019 12:29 Go to previous messageGo to next message
Jeno Attila Balasko is currently offline Jeno Attila BalaskoFriend
Messages: 78
Registered: September 2013
Location: Budapest, Hungary
Member

Hi,

the format of your path is wrong. Just to help, my TITAN installation path is this:
C:\Users\ethxxx\git\titan.core\Install

Follow this format or push the button "Browse..." and find your titan root dir. The format of the path will be correct!
Hopefully this helps. Waiting Your answer and
Best regards
Jeno Balaskó
TITAN team, Ericsson
Re: The version of the compiler could not be determined [message #1802787 is a reply to message #1802658] Fri, 15 February 2019 18:48 Go to previous messageGo to next message
Reepandeep  Kaur is currently offline Reepandeep KaurFriend
Messages: 7
Registered: January 2019
Junior Member
Hii ,

I have set the path and in cygwin installation i have included all the packages
install folder contain all the compiler but in titan the version could not be determined.
I would like to know it is necessary to make firewall disabled while setting the titan preferences.

Thanks and regards
Reepandeep Kaur
Re: The version of the compiler could not be determined [message #1802847 is a reply to message #1802787] Mon, 18 February 2019 08:01 Go to previous messageGo to next message
Jeno Attila Balasko is currently offline Jeno Attila BalaskoFriend
Messages: 78
Registered: September 2013
Location: Budapest, Hungary
Member

Hi ,

there isn't any firewall related problem.
Could you check your titan command line, please?
1. Open a cygwin terminal and type:
ttcn3_compiler -v 

You should receive something like this:
TTCN-3 and ASN.1 Compiler for the TTCN-3 Test Executor
Product number: CRL 113 200/6 R5B
Build date: Feb 15 2019 11:46:44
Compiled with: GCC 7.3.0
Using OpenSSL 1.0.2p  14 Aug 2018

Copyright (c) 2000-2018 Ericsson Telecom AB

License information:
---------------------------------------------------------------
License file : /cygdrive/c/Users/ethbaat/license_98.dat
Unique ID    : 98
Licensee     : Jen▒ Balask▒
E-mail       : jeno.balasko@ericsson.com
Company      : Ericsson Hungary
Department   : ETH/
Valid from   : Fri Sep 20 00:00:00 2002
Valid until  : Fri Mar 29 23:59:59 2019
Limitation   : USER
Host ID      : 00000000
Login name   : ethbaat
Versions     : from 1.1.pl0 until 1.99.pl99
Languages    : TTCN3 ASN1
Encoders     : RAW TEXT BER PER XER
Applications : CODEGEN TPGEN SINGLE MCTR HC LOGFORMAT
Max PTCs     : 10000
---------------------------------------------------------------
The license key is valid.

a)If you see this, your eclipse setting is the problem.
b)If you can't see this, your cygwin installation or your titan installation or your titan environment setting is the root cause if the problem. In this case I would suggest to read and check titan.core/README.cygwin again.

What do you see after executing the command
ttcn3_compiler -v
?

Waiting your answer
Jeno
Re: The version of the compiler could not be determined [message #1802858 is a reply to message #1802847] Mon, 18 February 2019 09:29 Go to previous messageGo to next message
Jeno Attila Balasko is currently offline Jeno Attila BalaskoFriend
Messages: 78
Registered: September 2013
Location: Budapest, Hungary
Member

I would also suggest to read topic https://www.eclipse.org/forums/index.php/m/1801833/#msg_1801833

BR
Jeno
Re: The version of the compiler could not be determined [message #1803046 is a reply to message #1802858] Thu, 21 February 2019 13:08 Go to previous messageGo to next message
Reepandeep  Kaur is currently offline Reepandeep KaurFriend
Messages: 7
Registered: January 2019
Junior Member
Hii,

I have checked by running $ compiler -v and is able to see only the TTCn3 and asn.1 compiler version not any license key also checked the path of environment variables but still facing the same issue

Thanks and regards
Reepandeep Kaur
Re: The version of the compiler could not be determined [message #1803048 is a reply to message #1802858] Thu, 21 February 2019 13:12 Go to previous messageGo to next message
Reepandeep  Kaur is currently offline Reepandeep KaurFriend
Messages: 7
Registered: January 2019
Junior Member
Hii,

I have checked by running $ compiler -v and is able to see only the TTCn3 and asn.1 compiler version not any license key also checked the path of environment variables but still facing the same issue

Thanks and regards
Reepandeep Kaur
Re: The version of the compiler could not be determined [message #1803087 is a reply to message #1803048] Fri, 22 February 2019 08:14 Go to previous message
Jeno Attila Balasko is currently offline Jeno Attila BalaskoFriend
Messages: 78
Registered: September 2013
Location: Budapest, Hungary
Member

Hi,
I should correct my information. Hopefully you have got a titan.core (in command line) and a titan.EclipsePlug-ins with version of open source. This open source versions are without license file and license file checking mechanism.
So the command compiler -v shall produce the same as I mentioned but without license info.
1.a Could you send us the copy of the output of
compiler -v 

( in terminal) and
1.b the snapshot of Eclipse Window>Preferences>TITAN Preferences. (Send more snapshots if possible.)
2. Can you send me
2.a the version of your titan.EclipsePlug-ins (Eclipse Help>About Eclipse platform>Installation details>Plug-ins) and
2.b the source where you downoaded it from?
3. Can you inform about your time zone or city? We should find a common "time slot"when we can change information quicker, more effectively. 3 days/cycle is not effective.
4. What is the point where you cannot continue your work with titan and eclipse?

Waiting your answer
Jeno
Previous Topic:regarding mctr_cli
Next Topic:ttcn3_makefilegen and subfolders
Goto Forum:
  


Current Time: Sat Jul 11 09:16:43 GMT 2020

Powered by FUDForum. Page generated in 0.01527 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top