Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » Bug?: MHandledToolItem not activated on handler registration via EHandlerService
Bug?: MHandledToolItem not activated on handler registration via EHandlerService [message #1801859] Mon, 28 January 2019 14:57 Go to next message
Thomas Fahrmeyer is currently offline Thomas FahrmeyerFriend
Messages: 30
Registered: July 2009
Location: Germany
Member
What should happen:

* have a MHandledToolItem in a toolbar, which uses command CMD_1
* no handler is defined for this CMD_1
* have two parts part_1, part_2
* in part_1 have a button or something which triggers the following logic once
* use the EHandlerService injected into part_1 to perform handlerService.activateHandler(CMD_1, new MySimpleHandler())
* expectation is that the item in the toolbar gets activated

What happens:

* item stays inactive
* activate part_2 and reactivate part_1, the icon gets activated

Can that be confirmed as bug, so I would file one. The same happens if the handler is created as MHandler and added to part1.getHandlers().add(mHandler).


Re: Bug?: MHandledToolItem not activated on handler registration via EHandlerService [message #1801860 is a reply to message #1801859] Mon, 28 January 2019 15:02 Go to previous messageGo to next message
Thomas Fahrmeyer is currently offline Thomas FahrmeyerFriend
Messages: 30
Registered: July 2009
Location: Germany
Member
If I do the same with the SWT renderer, everything works as expected. Item gets activate with EHandlerService API and via part.getHandlers().add(mHandler).
Re: Bug?: MHandledToolItem not activated on handler registration via EHandlerService [message #1801871 is a reply to message #1801860] Mon, 28 January 2019 19:20 Go to previous message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6505
Registered: July 2009
Senior Member
Sounds like a bug
Previous Topic:Announcing e(fx)clipse DriftFX
Next Topic:Error opening workspace after installing e(fx)
Goto Forum:
  


Current Time: Wed Sep 18 09:54:43 GMT 2019

Powered by FUDForum. Page generated in 0.02148 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top