Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Plugin not working on latest Eclipse versions(Plugin which was built using Eclipse-rcp Neon is not working on Eclipse Photon)
Plugin not working on latest Eclipse versions [message #1801101] Sun, 13 January 2019 23:12
Ammad Ahmed is currently offline Ammad AhmedFriend
Messages: 10
Registered: January 2019
Junior Member
I am trying to run the Eclipse plugin which was built using Neon release on the latest versions of Eclipse. So far it works fine on the Oxygen release but doesn't work on the other latest releases.

I have the source code of the plugin (on Neon-rcp) from which I created the plugin's jar file and installed it on Neon and Oxygen versions and it works fine but when I install it on Photon, 2018-09 and 2018-12 and launch the Eclipse IDE it gives me an error message to read the log file. In the log file it states that an error occurred while activating the bundle. I even installed the java 1.8.0_102 in which the plugin was built. I searched for solutions but couldn't find one which could solve this issue. Please see the log attached below.

I have no clue how to solve this problem as it works fine on Neon and Oxygen release. My main goal is to run it on the other latest releases. It would be a great help if someone point me in the right direction to solve this issue.

Thanks.

P.S : I don't have much experience with java and eclipse.
  • Attachment: log.txt
    (Size: 75.70KB, Downloaded 51 times)

[Updated on: Sun, 13 January 2019 23:14]

Report message to a moderator

Previous Topic:P2 requirements/information
Next Topic:Custom project with existing features
Goto Forum:
  


Current Time: Sat Sep 19 06:14:32 GMT 2020

Powered by FUDForum. Page generated in 0.01769 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top