Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Certificate trust popup during upgrade from 2018-09 to 2018-12
Certificate trust popup during upgrade from 2018-09 to 2018-12 [message #1800499] Sun, 30 December 2018 20:24 Go to next message
Matthias Schoettle is currently offline Matthias SchoettleFriend
Messages: 21
Registered: July 2009
Junior Member
Hello,

I am trying to upgrade my Eclipse 2018-09 to 2018-12 and I get a "Do you trust these certificates?" popup. I've never seen this before and the certificate in question raises some flags (see screenshots below).

Is this legit or not? I couldn't find any information about the signing certificate that is used by Eclipse to verify.
Re: Certificate trust popup during upgrade from 2018-09 to 2018-12 [message #1800759 is a reply to message #1800499] Mon, 07 January 2019 21:03 Go to previous message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 876
Registered: January 2012
Senior Member

I suspect this warning is due to 2018-12 using a new version of BouncyCastle. All bundles providing a JCE provider require being signed with with a JCE signing certificate from Oracle. Some details:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=391302#c55 (and comment 56)
https://www.oracle.com/technetwork/java/javase/tech/getcodesigningcertificate-361306.html


Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Previous Topic:How to remove ANT Configurations?
Next Topic:Eclipse 2018-12 exhibits quite a few UI usability issues (at least for Fedora 27)
Goto Forum:
  


Current Time: Fri Aug 14 09:14:27 GMT 2020

Powered by FUDForum. Page generated in 0.01814 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top