Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » SWTBot » 2018-12 Issues
2018-12 Issues [message #1800191] Fri, 21 December 2018 08:04 Go to next message
Matt Biggs is currently offline Matt BiggsFriend
Messages: 71
Registered: July 2009
Member
Has anyone tried SWTBot with 2018-12? I've just upgraded our app from 2018-09 and am having all kinds of problems. Nothing else changed, only the target platform.

It mainly seems to stem from mouse events. We have a bunch of custom widgets but seem to be getting negative coordinates in the mouse events when we use clicks that are Display.post'ed. I've tried coordinates that are toControl() and toDisplay() and neither works.

click(x,y, true)

If we don't post then it seems to work ok. I'm wondering if it's some HighDPI changes. Presumably it's an SWT issue not SWTBot but the app works fine normally, only fails during testing.
Re: 2018-12 Issues [message #1800227 is a reply to message #1800191] Fri, 21 December 2018 14:39 Go to previous messageGo to next message
Patrick Tasse is currently offline Patrick TasseFriend
Messages: 75
Registered: July 2009
Member
Hi Matt,

In Trace Compass project we have many SWTBot tests and we have seen no particular issue with 2018-12.

I recently merged a patch on SWTBot that fixes SWTBotTreeItem and SWTBotTableItem to 'properly' give focus to the tree/table when interacting with the item. That caused some disruption in our tests, but it was the tests that were wrong...

In any case, it's worth investigating which SWTBot widget is sending wrong mouse coordinates. In the past we were often just sending 0, 0 coordinates but have been getting slowly better. Sometimes the application does not care about the coordinates received in SWT events, perhaps in your application it's critical to have them correct due to the custom widgets. If we're attempting to set the correct coordinates in SWTBot but it's not calculated correctly due to a change in SWT, we would like to know.

We will need to know which platform you are using and especially which GTK version. SWT project no longer have the resource to fix issues with obsolete GTK versions, it seems.

Patrick
Re: 2018-12 Issues [message #1800232 is a reply to message #1800227] Fri, 21 December 2018 15:26 Go to previous message
Matt Biggs is currently offline Matt BiggsFriend
Messages: 71
Registered: July 2009
Member
Most of the widgets are custom ones, eg Canvas/Composite and owner drawn. One such issue was calling 'click'() on a SWTBotLabel though. I'm using GTK 3.24.1, our headless AWS nodes are 3.22.30 but also saw same problem on Windows 10. Our laptops are 4k then scaled up so we can actually see something. Headless AWS node isn't obviously though. I'm trying to get a stable build working first but will see if I can later clobber together a test app that reproduces it. Unless you get a chance to quickly try a label click().

Previous Topic:SWTBot test canot load class from application under testing
Next Topic:bot().textWithLabel() does not found appropriated text field
Goto Forum:
  


Current Time: Sat Jul 11 09:08:14 GMT 2020

Powered by FUDForum. Page generated in 0.01541 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top