Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » P2 requirements/information
P2 requirements/information [message #1799018] Wed, 28 November 2018 18:28
Jan Jansen is currently offline Jan JansenFriend
Messages: 15
Registered: October 2018
Junior Member
Hi all,

as a hobby project I'm building a P2 repository hosting application, since current solutions seem to be either Nexus (old-ish version) with the unzip plugin, or Artifactory with a license that costs a boatload of money.

However, I cannot find anywhere what would constitute a proper P2 repository such that, for instance, Eclipse can use it for retrieval of artifacts.

I'm looking for information such as which HTTP requests applications looking for a P2 repository send, and what kind of responses they expect.

If anyone could point me in the right direction, perhaps some useful documentation, I'd be very grateful.

Kind regards.
Previous Topic:Reference the latest IU in target file
Next Topic:Plugin not working on latest Eclipse versions
Goto Forum:
  


Current Time: Sat Sep 19 07:06:18 GMT 2020

Powered by FUDForum. Page generated in 0.01296 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top