Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » scout » Error on the start of the simple project(Eclipse IDE for Scout Developers Version: 2018-09 (4.9.0) Build id: 20180917-1800)
Error on the start of the simple project [message #1797955] Fri, 09 November 2018 08:18 Go to next message
marco giudici is currently offline marco giudiciFriend
Messages: 201
Registered: February 2013
Location: Italy
Senior Member
Hi,
I'm starting to use Scout under Eclipse Pothon, I create a new project and when I try to start the execution, return to me the following errors
2018-11-09 09:07:30,640 INFO  [Thread-9] org.eclipse.scout.rt.platform.inventory.ClassInventory.<clinit>(ClassInventory.java:44) - Finished building jandex class inventory in 78.841398 ms. Total class count: 1261 - MDC[]
2018-11-09 09:07:30,704 ERROR [Thread-9] org.eclipse.scout.rt.platform.internal.PlatformImplementor.start(PlatformImplementor.java:144) - Error during platform startup - MDC[]
java.lang.UnsupportedClassVersionError: null
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
	at java.lang.reflect.Constructor.newInstance(Unknown Source)
	at java.util.concurrent.ForkJoinTask.getThrowableException(Unknown Source)
	at java.util.concurrent.ForkJoinTask.reportException(Unknown Source)
	at java.util.concurrent.ForkJoinTask.invoke(Unknown Source)
	at java.util.stream.ForEachOps$ForEachOp.evaluateParallel(Unknown Source)
	at java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateParallel(Unknown Source)
	at java.util.stream.AbstractPipeline.evaluate(Unknown Source)
	at java.util.stream.ReferencePipeline.forEach(Unknown Source)
	at java.util.stream.ReferencePipeline$Head.forEach(Unknown Source)
	at org.eclipse.scout.rt.platform.internal.BeanFilter.collect(BeanFilter.java:66)
	at org.eclipse.scout.rt.platform.internal.PlatformImplementor.createBeanManager(PlatformImplementor.java:213)
	at org.eclipse.scout.rt.platform.internal.PlatformImplementor.start(PlatformImplementor.java:133)
	at org.eclipse.scout.rt.platform.internal.PlatformStarter.run(PlatformStarter.java:29)
Caused by: java.lang.UnsupportedClassVersionError: org/zeiss/mo/scout/czvedicontroller/czvedicontroller/server/helloworld/HelloWorldService has been compiled by a more recent version of the Java Runtime (class file version 54.0), this version of the Java Runtime only recognizes class file versions up to 52.0
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(Unknown Source)
	at java.security.SecureClassLoader.defineClass(Unknown Source)
	at java.net.URLClassLoader.defineClass(Unknown Source)
	at java.net.URLClassLoader.access$100(Unknown Source)
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Unknown Source)
	at org.eclipse.scout.rt.platform.inventory.internal.JandexClassInfo.ensureClassLoaded(JandexClassInfo.java:58)
	at org.eclipse.scout.rt.platform.inventory.internal.JandexClassInfo.resolveClass(JandexClassInfo.java:117)
	at org.eclipse.scout.rt.platform.internal.BeanFilter.addBean(BeanFilter.java:119)
	at org.eclipse.scout.rt.platform.internal.BeanFilter.collect(BeanFilter.java:114)
	at org.eclipse.scout.rt.platform.internal.BeanFilter.collectWithSubClasses(BeanFilter.java:86)
	at org.eclipse.scout.rt.platform.internal.BeanFilter.lambda$0(BeanFilter.java:66)
	at java.util.stream.ForEachOps$ForEachOp$OfRef.accept(Unknown Source)
	at java.util.HashMap$KeySpliterator.forEachRemaining(Unknown Source)
	at java.util.stream.AbstractPipeline.copyInto(Unknown Source)
	at java.util.stream.ForEachOps$ForEachTask.compute(Unknown Source)
	at java.util.concurrent.CountedCompleter.exec(Unknown Source)
	at java.util.concurrent.ForkJoinTask.doExec(Unknown Source)
	at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(Unknown Source)
	at java.util.concurrent.ForkJoinPool.runWorker(Unknown Source)
	at java.util.concurrent.ForkJoinWorkerThread.run(Unknown Source)
Exception in thread "Thread-9" java.lang.UnsupportedClassVersionError
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
	at java.lang.reflect.Constructor.newInstance(Unknown Source)
	at java.util.concurrent.ForkJoinTask.getThrowableException(Unknown Source)
	at java.util.concurrent.ForkJoinTask.reportException(Unknown Source)
	at java.util.concurrent.ForkJoinTask.invoke(Unknown Source)
	at java.util.stream.ForEachOps$ForEachOp.evaluateParallel(Unknown Source)
	at java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateParallel(Unknown Source)
	at java.util.stream.AbstractPipeline.evaluate(Unknown Source)
	at java.util.stream.ReferencePipeline.forEach(Unknown Source)
	at java.util.stream.ReferencePipeline$Head.forEach(Unknown Source)
	at org.eclipse.scout.rt.platform.internal.BeanFilter.collect(BeanFilter.java:66)
	at org.eclipse.scout.rt.platform.internal.PlatformImplementor.createBeanManager(PlatformImplementor.java:213)
	at org.eclipse.scout.rt.platform.internal.PlatformImplementor.start(PlatformImplementor.java:133)
	at org.eclipse.scout.rt.platform.internal.PlatformStarter.run(PlatformStarter.java:29)
Caused by: java.lang.UnsupportedClassVersionError: org/zeiss/mo/scout/czvedicontroller/czvedicontroller/server/helloworld/HelloWorldService has been compiled by a more recent version of the Java Runtime (class file version 54.0), this version of the Java Runtime only recognizes class file versions up to 52.0
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(Unknown Source)
	at java.security.SecureClassLoader.defineClass(Unknown Source)
	at java.net.URLClassLoader.defineClass(Unknown Source)
	at java.net.URLClassLoader.access$100(Unknown Source)
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Unknown Source)
	at org.eclipse.scout.rt.platform.inventory.internal.JandexClassInfo.ensureClassLoaded(JandexClassInfo.java:58)
	at org.eclipse.scout.rt.platform.inventory.internal.JandexClassInfo.resolveClass(JandexClassInfo.java:117)
	at org.eclipse.scout.rt.platform.internal.BeanFilter.addBean(BeanFilter.java:119)
	at org.eclipse.scout.rt.platform.internal.BeanFilter.collect(BeanFilter.java:114)
	at org.eclipse.scout.rt.platform.internal.BeanFilter.collectWithSubClasses(BeanFilter.java:86)
	at org.eclipse.scout.rt.platform.internal.BeanFilter.lambda$0(BeanFilter.java:66)
	at java.util.stream.ForEachOps$ForEachOp$OfRef.accept(Unknown Source)
	at java.util.HashMap$KeySpliterator.forEachRemaining(Unknown Source)
	at java.util.stream.AbstractPipeline.copyInto(Unknown Source)
	at java.util.stream.ForEachOps$ForEachTask.compute(Unknown Source)
	at java.util.concurrent.CountedCompleter.exec(Unknown Source)
	at java.util.concurrent.ForkJoinTask.doExec(Unknown Source)
	at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(Unknown Source)
	at java.util.concurrent.ForkJoinPool.runWorker(Unknown Source)
	at java.util.concurrent.ForkJoinWorkerThread.run(Unknown Source)
2018-11-09 09:07:30,712 WARN  [main] org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:549) - Failed startup of context o.e.s.d.j.P_WebAppContext@cb0ed20{/,file:///C:/Projects_SDE/Pothon/czvedicontroller/czvedicontroller.server.app.dev/src/main/webapp/,UNAVAILABLE} - MDC[]
org.eclipse.scout.rt.platform.exception.PlatformException: The platform is in an invalid state.
	at org.eclipse.scout.rt.platform.internal.PlatformImplementor.throwOnPlatformInvalid(PlatformImplementor.java:94)
	at org.eclipse.scout.rt.platform.internal.PlatformImplementor.awaitPlatformStarted(PlatformImplementor.java:84)
	at org.eclipse.scout.rt.server.commons.WebappEventListener.contextInitialized(WebappEventListener.java:44)
	at org.eclipse.jetty.server.handler.ContextHandler.callContextInitialized(ContextHandler.java:876)
	at org.eclipse.jetty.servlet.ServletContextHandler.callContextInitialized(ServletContextHandler.java:532)
	at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:839)
	at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:344)
	at org.eclipse.jetty.webapp.WebAppContext.startWebapp(WebAppContext.java:1480)
	at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1442)
	at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:799)
	at org.eclipse.jetty.servlet.ServletContextHandler.doStart(ServletContextHandler.java:261)
	at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:540)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
	at org.eclipse.jetty.util.component.ContainerLifeCycle.start(ContainerLifeCycle.java:131)
	at org.eclipse.jetty.server.Server.start(Server.java:452)
	at org.eclipse.jetty.util.component.ContainerLifeCycle.doStart(ContainerLifeCycle.java:105)
	at org.eclipse.jetty.server.handler.AbstractHandler.doStart(AbstractHandler.java:113)
	at org.eclipse.jetty.server.Server.doStart(Server.java:419)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
	at org.eclipse.scout.dev.jetty.JettyServer.start(JettyServer.java:95)
	at org.eclipse.scout.dev.jetty.JettyServer.main(JettyServer.java:56)
2018-11-09 09:07:30,761 INFO  [main] org.eclipse.jetty.server.AbstractConnector.doStart(AbstractConnector.java:280) - Started ServerConnector@6385cb26{HTTP/1.1,[http/1.1]}{0.0.0.0:8080} - MDC[]
Exception in thread "main" org.eclipse.scout.rt.platform.exception.PlatformException: The platform is in an invalid state.
	at org.eclipse.scout.rt.platform.internal.PlatformImplementor.throwOnPlatformInvalid(PlatformImplementor.java:94)
	at org.eclipse.scout.rt.platform.internal.PlatformImplementor.awaitPlatformStarted(PlatformImplementor.java:84)
	at org.eclipse.scout.rt.server.commons.WebappEventListener.contextInitialized(WebappEventListener.java:44)
	at org.eclipse.jetty.server.handler.ContextHandler.callContextInitialized(ContextHandler.java:876)
	at org.eclipse.jetty.servlet.ServletContextHandler.callContextInitialized(ServletContextHandler.java:532)
	at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:839)
	at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:344)
	at org.eclipse.jetty.webapp.WebAppContext.startWebapp(WebAppContext.java:1480)
	at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1442)
	at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:799)
	at org.eclipse.jetty.servlet.ServletContextHandler.doStart(ServletContextHandler.java:261)
	at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:540)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
	at org.eclipse.jetty.util.component.ContainerLifeCycle.start(ContainerLifeCycle.java:131)
	at org.eclipse.jetty.server.Server.start(Server.java:452)
	at org.eclipse.jetty.util.component.ContainerLifeCycle.doStart(ContainerLifeCycle.java:105)
	at org.eclipse.jetty.server.handler.AbstractHandler.doStart(AbstractHandler.java:113)
	at org.eclipse.jetty.server.Server.doStart(Server.java:419)
	at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
	at org.eclipse.scout.dev.jetty.JettyServer.start(JettyServer.java:95)
	at org.eclipse.scout.dev.jetty.JettyServer.main(JettyServer.java:56)


this is the version of Java that I have on my machine
index.php/fa/34295/0/

and this is the version of maven on my machine
index.php/fa/34296/0/

I think that on my installation is missing something, but honestly for the moment I don't know what.
Suggestion are welcome

Thanks in advance for any help

Marco

[Updated on: Fri, 09 November 2018 08:34]

Report message to a moderator

Re: Error on the start of the simple project [message #1797956 is a reply to message #1797955] Fri, 09 November 2018 08:30 Go to previous messageGo to next message
The Maddes is currently offline The MaddesFriend
Messages: 44
Registered: October 2018
Member
Hey man,

maybe this link might be help you to find a solution. Either your installed JDK or the Maven Compiliation might be the thing.

https://stackoverflow.com/questions/47876051/has-been-compiled-by-a-more-recent-version-of-the-java-runtime-class-file-versi?noredirect=1&lq=1
Re: Error on the start of the simple project [message #1797963 is a reply to message #1797956] Fri, 09 November 2018 09:26 Go to previous messageGo to next message
Patrick Bänziger is currently offline Patrick BänzigerFriend
Messages: 90
Registered: September 2011
Member
Hi there

I think The Maddes is correct: It sounds like you compiled the application on a newer Java version and run it on an older version.
Unless you specify that you want to target an older version, the compiler will target the version you compile it on -- which can't be read by older versions.


  • Version 54 (the version you compiled it with) corresponds to Java 10
  • Version 52 (the version you run it with) corresponds to Java 8


Please note: Eclipse Scout may not run out-of-the-box with a JDK version greater than Java 8.
You may need to set your Eclipse to run with the JDK 8 as described in the Beginners Guide Appendix (towards the end of section B.3).
Re: Error on the start of the simple project [message #1797965 is a reply to message #1797963] Fri, 09 November 2018 09:41 Go to previous messageGo to next message
marco giudici is currently offline marco giudiciFriend
Messages: 201
Registered: February 2013
Location: Italy
Senior Member
Hi,
my Eclipse Photon is set to use JDK 1.8
index.php/fa/34297/0/

This is enough or not?
Re: Error on the start of the simple project [message #1797972 is a reply to message #1797965] Fri, 09 November 2018 11:04 Go to previous messageGo to next message
The Maddes is currently offline The MaddesFriend
Messages: 44
Registered: October 2018
Member
What is in your project pom.xml?
For me its:
<properties>
    <jdk.source.version>1.8</jdk.source.version>
    <org.eclipse.scout.rt.version>8.0.0.021_Simrel_2018_09</org.eclipse.scout.rt.version>
  </properties>


Maybe thats a point to step into?
Re: Error on the start of the simple project [message #1797973 is a reply to message #1797972] Fri, 09 November 2018 11:24 Go to previous messageGo to next message
marco giudici is currently offline marco giudiciFriend
Messages: 201
Registered: February 2013
Location: Italy
Senior Member
Thanks for your hint, in my project pom.xml this value is 10 and after I chenged to 1.8 as yours everything start to work.

Many thanks
Re: Error on the start of the simple project [message #1797986 is a reply to message #1797973] Fri, 09 November 2018 14:25 Go to previous message
The Maddes is currently offline The MaddesFriend
Messages: 44
Registered: October 2018
Member
Happy I could help you out :)
You're welcome!
Previous Topic:Starting scheduled job on server
Next Topic:Table Menubar at top
Goto Forum:
  


Current Time: Wed Oct 23 12:49:11 GMT 2019

Powered by FUDForum. Page generated in 0.01409 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top