Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » birt-runtime-4.8.0(birt-runtime-4.8.0 - Error)
birt-runtime-4.8.0 [message #1797906] Thu, 08 November 2018 11:29 Go to next message
Alan Francis is currently offline Alan FrancisFriend
Messages: 3
Registered: November 2018
Junior Member
I tried to run the command from the /opt/brit/Runtime/ReportEngine folder.



export BIRT_HOME=/opt/birt/Runtime
cd $BIRT_HOME/ReportEngine/
./genReport.sh -f PDF -o output.pdf /opt/birt/invoice.rptdesign


I get the following error:

 
Error: Could not find or load main class org.eclipse.birt.report.engine.api.ReportRunner


Could you please point me where am I going wrong?

Thanks
Alan
Re: birt-runtime-4.8.0 [message #1797947 is a reply to message #1797906] Fri, 09 November 2018 04:37 Go to previous messageGo to next message
Colin Sutton is currently offline Colin SuttonFriend
Messages: 106
Registered: July 2009
Senior Member
I reported that genReport was not working nearly 3 years ago (https://bugs.eclipse.org/bugs/show_bug.cgi?id=484453) with BIRT 4.5,
only got around to retesting with BIRT 4.7 last week - I'm disappointed it is still there with 4.8.
I worked around it in 4.7 by replacing genreport with the attached and calling it as follows (adjust the paths to suit your system).

set BIRT_HOME=E:\birt-runtime-4.7.0-20170622
set JAVA_HOME=C:\Program Files\Java\jre1.8.0_191
set Path=%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\Program Files\TortoiseSVN\bin;C:\Program Files\Java\jre1.8.0_191\bin
echo %time%
call E:\birt-runtime-4.7.0-20170622\ReportEngine\genReport.bat -o E:\[output] E:\[report].rptdesign

See also bug report https://bugs.eclipse.org/bugs/show_bug.cgi?id=473450
Re: birt-runtime-4.8.0 [message #1797959 is a reply to message #1797947] Fri, 09 November 2018 09:18 Go to previous messageGo to next message
Alan Francis is currently offline Alan FrancisFriend
Messages: 3
Registered: November 2018
Junior Member
Thank you Colin,

By using the .bat file provided by you it worked perfect and got the output. I would like to know if there is any work around with the genReport.sh file?


Thanks in advance
Alan

[Updated on: Fri, 09 November 2018 09:46]

Report message to a moderator

Re: birt-runtime-4.8.0 [message #1797999 is a reply to message #1797959] Fri, 09 November 2018 19:58 Go to previous messageGo to next message
Colin Sutton is currently offline Colin SuttonFriend
Messages: 106
Registered: July 2009
Senior Member
I have not used genReport.sh but I suspect that you could fix it by setting the paths to BIRT_HOME, WORK_DIR and java.
Re: birt-runtime-4.8.0 [message #1798058 is a reply to message #1797999] Mon, 12 November 2018 05:38 Go to previous messageGo to next message
Alan Francis is currently offline Alan FrancisFriend
Messages: 3
Registered: November 2018
Junior Member
Hi Colin...

Got the .sh file working. BIRTCLASSPATH was not set which was the reason the .sh file was giving the class missing/not loading error. Thank you for your time and advice.
Re: birt-runtime-4.8.0 [message #1798925 is a reply to message #1798058] Tue, 27 November 2018 14:13 Go to previous message
Ramesh M is currently offline Ramesh MFriend
Messages: 1
Registered: November 2018
Junior Member
Hi,

Can you please help us what was done to overcome this issue since we are also facing the same issue while running the .sh script (.sh file was giving the class missing/not loading error).


Thanks,
Ramesh
Previous Topic:IRR function
Next Topic:Dynamic X-axis marker ranges based on global variables
Goto Forum:
  


Current Time: Fri Jul 19 02:40:22 GMT 2019

Powered by FUDForum. Page generated in 0.02074 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top