Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » VIATRA » Tutorial: Batch transformation
Tutorial: Batch transformation [message #1797705] Mon, 05 November 2018 13:17 Go to next message
Alex LJ is currently offline Alex LJFriend
Messages: 1
Registered: October 2018
Junior Member
Hi, i'm following VIATRA tutorial, but i'm getting errors reaching to this point:

https://www.eclipse.org/viatra/documentation/tutorial.html#_batch_transformations

I created a new Viatra Query project and a new Query file but when i copy the code provided i get all of the errors shown in the included picture. What am i missing?

Thanks in advance

  • Attachment: errors.png
    (Size: 223.88KB, Downloaded 46 times)
Re: Tutorial: Batch transformation [message #1797755 is a reply to message #1797705] Tue, 06 November 2018 07:56 Go to previous messageGo to next message
Zoltan Ujhelyi is currently offline Zoltan UjhelyiFriend
Messages: 379
Registered: July 2015
Senior Member
Hi Alex,

most likely your query project does not have the metamodel on its classpath (e.g. added as a depenendency). In this case, as described in https://www.eclipse.org/viatra/documentation/tutorial.html#_define_your_first_query, you have to add the `org.eclipse.viatra.examples.cps.model` plug-in as a dependency in the MANIFEST.MF file of your query project.

Best regards,
Zoltán
Re: Tutorial: Batch transformation [message #1803970 is a reply to message #1797755] Thu, 14 March 2019 15:14 Go to previous messageGo to next message
Maria Bonner is currently offline Maria BonnerFriend
Messages: 1
Registered: March 2019
Junior Member
Hey Zoltán,

I have the same problem. However, when I try to add the the `org.eclipse.viatra.examples.cps.model` plug-in as a dependency in the MANIFEST.MF file, the Plug-in manager does not display any matching items. It seems like some packages are missing after installation. Any idea how the problem can be fixed?

Thanks in advance,
Maria
Re: Tutorial: Batch transformation [message #1804140 is a reply to message #1803970] Tue, 19 March 2019 08:37 Go to previous message
Zoltan Ujhelyi is currently offline Zoltan UjhelyiFriend
Messages: 379
Registered: July 2015
Senior Member
Hi Maria,

in general, I see two reasons this might be the case:

1) the CPS metamodel is not installed to your Eclipse installation/target platform. The metamodel is installable from http://download.eclipse.org/viatra/examples/cps
2) If the metamodel is already installed, then you might be using a custom target platform (e.g. not the running platform), that does not include this. To check it, go to Preferences, and look at the Plug-in Development/Target Platform page and check the currently selected target platform.

I hope this was helpful. If not, feel free to ask for further clarifications.

Best regards,
Zoltán
Previous Topic:Model refinement with viatra
Next Topic:Generic pattern matcher invoking registered pattern from a bundle
Goto Forum:
  


Current Time: Sun Nov 29 08:48:00 GMT 2020

Powered by FUDForum. Page generated in 0.07349 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top