Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Can't install jubula for committers using oomph
Can't install jubula for committers using oomph [message #1797114] Thu, 25 October 2018 12:57 Go to next message
romano clemensFriend
Messages: 5
Registered: July 2018
Junior Member
So we've tried different ways to set up a build environment for Jubula to try and implement custom extensions.

The only thing we got working so far was a jenkins build, which is good to have but not really nice for developing proper.

Tried installing it on windows using oomph and the following guide https://wiki.eclipse.org/Jubula/JubulaContribGuide#Via_Oomph
The following error was spat out on the post-launch hooks, using the 2018-09 option and a similar error occured using the oxygen version.
Manually importing the repository just left me with countless errors, regarding missing artifacts, type resolving and others.
ERROR: org.eclipse.pde.core code=0 Problems occurred while resolving the target contents
  at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:280)
  at org.eclipse.oomph.util.pde.TargetPlatformUtil.activateTargetDefinition(TargetPlatformUtil.java:151)
  at org.eclipse.oomph.targlets.internal.core.TargletContainer.forceUpdate(TargletContainer.java:787)
  at org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl$4.run(TargletTaskImpl.java:1167)
  at org.eclipse.oomph.util.pde.TargetPlatformUtil.runWithTargetPlatformService(TargetPlatformUtil.java:120)
  at org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl.perform(TargletTaskImpl.java:1033)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3334)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.access$1(SetupTaskPerformer.java:3277)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:4504)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2292)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2319)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:4498)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:4496)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3268)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3243)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3143)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:575)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:701)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)
  ERROR: org.eclipse.equinox.p2.director code=10053 Cannot complete the install because one or more required items could not be found.
    ERROR: org.eclipse.equinox.p2.director code=0 Software being installed: artificial_root 1.0.0.v1540466604311
    ERROR: org.eclipse.equinox.p2.director code=0 Missing requirement: Jubula Functional Testing 7.0.0.v20181025-132321 (org.eclipse.jubula.feature.feature.group 7.0.0.v20181025-132321) requires 'org.eclipse.equinox.p2.iu; org.eclipse.mylyn.commons.feature.group 0.0.0' but it could not be found
    ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
      ERROR: org.eclipse.equinox.p2.director code=0 From: artificial_root 1.0.0.v1540466604311
      ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.equinox.p2.iu; org.eclipse.jubula.feature.feature.group 0.0.0


A colleague tried to get the buildchain set up manually on linux but there also were several errors with unresolvable bundles or errors in pom-files.

Any help would be appreciated.
Re: Can't install jubula for committers using oomph [message #1797766 is a reply to message #1797114] Tue, 06 November 2018 09:38 Go to previous message
Marvin Mueller is currently offline Marvin MuellerFriend
Messages: 192
Registered: March 2012
Senior Member
Are you trying to write extensions, so that you are able to support custom components, or do you want to really extend Jubula in some functionallity. If you just want to support custom components please refer to the documentation[1][2].

Thanks for reporting the problem, I will check it.

best regards
Marvin Mueller

[1] https://help.eclipse.org/2018-09/topic/org.eclipse.jubula.client.ua.help/content/html/developerManual/toolkitExtension/ch03.html
[2] https://help.eclipse.org/2018-09/topic/org.eclipse.jubula.client.ua.help/content/html/developerManual/extensionWizard/ch05.html
Previous Topic:Error when exporting project
Next Topic:User defined functions: external methods HowTo
Goto Forum:
  


Current Time: Thu Nov 21 03:28:35 GMT 2019

Powered by FUDForum. Page generated in 0.01525 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top