Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » How to install Moka in Papyrus 2018-9?(dependencies not found)
How to install Moka in Papyrus 2018-9? [message #1797081] Thu, 25 October 2018 01:19 Go to next message
Julio Machado is currently offline Julio MachadoFriend
Messages: 1
Registered: October 2018
Junior Member
How to install Moka in Papyrus 2018-9?
Using the Moka update site, it can't find all dependencies.
I've tried the update sites mentioned in other posts but none worked.
Any idea?
Thanks in advance.
Re: How to install Moka in Papyrus 2018-9? [message #1797287 is a reply to message #1797081] Mon, 29 October 2018 15:00 Go to previous messageGo to next message
Quentin Le Menez is currently offline Quentin Le MenezFriend
Messages: 47
Registered: September 2014
Location: Paris Saclay, France
Member
Hi Julio,

indeed if you are trying to install Moka from the update site [1] then all you will have is an Oxygen compatible version. as far as I can tell
If you want to install it on a 2018-09 you will have to fetch it from the Jenkins job directly [2] as it has not yet been published.

You might have to add the fllowing update sites to resolve the additional dependencies that are not part of the release train (depending on what you need, i.e. just the Core or the Cosim feature as well):
1- Orbit: http://download.eclipse.org/tools/ajdt/47/dev/update/ajdt-e47-2.2.4.201704242114/
2- Nebula: http://download.eclipse.org/nebula/releases/1.2.0
3- AspectJ: http://download.eclipse.org/tools/ajdt/47/dev/update/ajdt-e47-2.2.4.201704242114/


HTH,
Cheers,
Quentin

[1] http://download.eclipse.org/modeling/mdt/papyrus/components/moka/?d
[2] https://ci.eclipse.org/papyrus/view/Moka/job/papyrus-moka-master/lastSuccessfulBuild/artifact/releng/org.eclipse.papyrus.moka.p2/target/repository/


Re: How to install Moka in Papyrus 2018-9? [message #1797288 is a reply to message #1797287] Mon, 29 October 2018 15:00 Go to previous message
Quentin Le Menez is currently offline Quentin Le MenezFriend
Messages: 47
Registered: September 2014
Location: Paris Saclay, France
Member
Sorry the orbit repository should have read: http://download.eclipse.org/tools/orbit/downloads/drops/R20170307180635/repository/
Previous Topic:Error Starting Papyrus RCP 4.1.0
Next Topic:State Machine Inheritance
Goto Forum:
  


Current Time: Wed Jan 22 02:28:52 GMT 2020

Powered by FUDForum. Page generated in 0.01646 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top