Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Error Starting Papyrus RCP 4.1.0('Failed to find a Main Class' error on starting Papyrus RCP 4.1.0)
Error Starting Papyrus RCP 4.1.0 [message #1796764] Thu, 18 October 2018 15:22 Go to next message
Doug Bowman is currently offline Doug BowmanFriend
Messages: 4
Registered: October 2018
Junior Member
I downloaded RCP 4.1.0 for Windows 32-bit, unzipped, and ran the papyrus.exe binary. When I did, the Papyrus startup splash screen appeared followed by this error message:

index.php/fa/34114/0/

Text of error message:

Failed to find a Main Class in 
"C:\Software\papyrus-2018-09-4.1.0-win32\Papyrus\\plugins\org.eclipse.equinox.launcher_1.5.100.v20180827-1352.jar".


It looks to me like there is just an extra '\' character after the Papyrus directory, so I attempted to find a variable in the papyrus.ini file to adjust the path. I could not figure out how to change this, if this is indeed the issue, as the path parameters I saw were all relative paths from the Papyrus directory.

Any ideas on how to fix this error? Thanks for your time.
Re: Error Starting Papyrus RCP 4.1.0 [message #1796779 is a reply to message #1796764] Thu, 18 October 2018 18:47 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6568
Registered: July 2009
Senior Member
Hi

The \\ is inelegant but not usually a problem. However it suggests that two paths have been concatenated wrong.

Have a look for the correct path prefix for plugins\org.eclipse.equinox.launcher_1.5.100.v20180827-1352.jar

Regards

Ed Willink
Re: Error Starting Papyrus RCP 4.1.0 [message #1796780 is a reply to message #1796779] Thu, 18 October 2018 19:12 Go to previous messageGo to next message
Doug Bowman is currently offline Doug BowmanFriend
Messages: 4
Registered: October 2018
Junior Member
Thanks for the reply, Ed. From what I can tell, the error is showing the correct path, if the extra '\' was removed (though my caffeine levels may dangerously low):

index.php/fa/34115/0/

The papyrus.ini file seems to have the -startup parameter pointing to that location, without any slashes before the relative path. Here is the papyrus.ini file:

-startup
plugins\org.eclipse.equinox.launcher_1.5.100.v20180827-1352.jar
--launcher.library
plugins\org.eclipse.equinox.launcher.win32.win32.x86_1.1.800.v20180827-1352
-showsplash
org.eclipse.papyrus.rcp
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vmargs
-Xms128m
-Xmx900m
-Dosgi.bundlefile.limit=200


The papyrus.ini file is located at C:\Software\papyrus-2018-09-4.1.0-win32\Papyrus\, so I believe it should be in the correct location for the relative paths mentioned in the file to work properly. Also, if I change the arguments to -startup and --launcher.library, it changes the file path mentioned in the error message shown in the first post.

Is it possible to set another parameter in the papyrus.ini file that will allow me to change the first path that the program searches for the \plugins\ directory? This may allow me to remove the extra backslash to see if this is the problem.

And I don't mean to point the attention only at the extra backslash, as this may not be the cause of the issue--just the first thing that jumped out at me.

Thanks again for any help.
Re: Error Starting Papyrus RCP 4.1.0 [message #1796837 is a reply to message #1796780] Fri, 19 October 2018 15:56 Go to previous messageGo to next message
Quentin Le Menez is currently offline Quentin Le MenezFriend
Messages: 47
Registered: September 2014
Location: Paris Saclay, France
Member
Hi Doug,

I do not have access to a VM to test the 32bit release where I am right now but I'll look into as soon as I can.
Thanks for the feedback though, its always appreciated ! And Thanks Ed for the help, I agreee that \\ is very strange and will look into it.

Cheers,
Quentin
Re: Error Starting Papyrus RCP 4.1.0 [message #1796842 is a reply to message #1796837] Fri, 19 October 2018 16:24 Go to previous messageGo to next message
Quentin Le Menez is currently offline Quentin Le MenezFriend
Messages: 47
Registered: September 2014
Location: Paris Saclay, France
Member
Hi again,

Just as a complement of information: your installed JDK is 1.8_*** right ? (both installed and pointed by your local variable). if you could try to set the vm to it as a test it would be great:
-vm
C:/$JavaPath/Java/jdk1.8.0_***/bin/javaw.exe
Re: Error Starting Papyrus RCP 4.1.0 [message #1796843 is a reply to message #1796837] Fri, 19 October 2018 16:24 Go to previous messageGo to next message
Doug Bowman is currently offline Doug BowmanFriend
Messages: 4
Registered: October 2018
Junior Member
Quentin,

Thanks for taking a look. Let me know if there is anything I can do to assist.

Regards,
Doug Bowman
Re: Error Starting Papyrus RCP 4.1.0 [message #1796852 is a reply to message #1796843] Fri, 19 October 2018 18:12 Go to previous messageGo to next message
Doug Bowman is currently offline Doug BowmanFriend
Messages: 4
Registered: October 2018
Junior Member
Quentin,

This did the trick, thanks for the suggestion. For posterity, here is exactly what I did: I installed version 1.8 and added the -vm argument to the papyrus.ini file as you suggested.

On further investigation, it appears that I do not have Java in my $env:path at all. I think this was required due to some other programs at work needing to use older versions of Java, and the Java directory in the path got in the way. Nonetheless, this issue is fixed.

Thanks again for the assistance.


Regards,
Doug Bowman
Re: Error Starting Papyrus RCP 4.1.0 [message #1797016 is a reply to message #1796852] Wed, 24 October 2018 07:28 Go to previous message
Quentin Le Menez is currently offline Quentin Le MenezFriend
Messages: 47
Registered: September 2014
Location: Paris Saclay, France
Member
Hi Doug,

Glad this worked and for the feedback ! :)

Cheers,
Quentin
Previous Topic:Papyrus Oxygen Alf Editor
Next Topic:How to install Moka in Papyrus 2018-9?
Goto Forum:
  


Current Time: Wed Jan 22 02:17:01 GMT 2020

Powered by FUDForum. Page generated in 0.02333 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top