Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » Cannot complete the install because of a conflicting dependency(While installing RTC iFix version facing dependency issue and installation not able to proceed)
Cannot complete the install because of a conflicting dependency [message #1796106] Fri, 05 October 2018 08:46
Dinesh N is currently offline Dinesh NFriend
Messages: 1
Registered: October 2018
Junior Member
I have tried installing RTC iFix using p2 director, while installing I am facing issue like:

Installing com.ibm.team.enterprise.build.ui 1.3.100.v20180217_0421.
[exec] Installation failed.
[exec] Cannot complete the install because of a conflicting dependency.
[exec] Software being installed: Enterprise Common Build UI 1.3.100.v20180217_0421 (com.ibm.team.enterprise.build.ui 1.3.100.v20180217_0421)
[exec] Software currently installed: Rational Team Concert Client Feature 4.5.800.v20171103_2316 (com.ibm.team.rtc.client.feature.feature.group 4.5.800.v20171103_2316)
[exec] Only one of the following can be installed at once:
[exec] Enterprise Common Build UI 1.3.100.v20171020_1727 (com.ibm.team.enterprise.build.ui 1.3.100.v20171020_1727)
[exec] Enterprise Common Build UI 1.3.100.v20180217_0421 (com.ibm.team.enterprise.build.ui 1.3.100.v20180217_0421)
[exec] Cannot satisfy dependency:
[exec] From: Enterprise Extensions Build UI Feature 1.2.1300.v20171103_0616 (com.ibm.team.enterprise.build.feature.ui.feature.group 1.2.1300.v20171103_0616)
[exec] To: com.ibm.team.enterprise.build.ui [1.3.100.v20171020_1727]
[exec] Cannot satisfy dependency:
[exec] From: Rational Team Concert Client Feature 4.5.800.v20171103_2316 (com.ibm.team.rtc.client.feature.feature.group 4.5.800.v20171103_2316)
[exec] To: com.ibm.team.enterprise.build.feature.ui.feature.group [1.2.1300.v20171103_0616]

One thing is, the plugin "com.ibm.team.enterprise.build.ui" is already installed during RTC installation and same plugin with different version name is trying to install in same eclipse and so it shows the issue.

But we don't need to uninstall the previous version and install the new version as we need both the versions.

While installing manually it does not show any issue. But while installing using p2 director I am facing the issue and currently I am blocked. Kindly provide inputs if anyone faced the issue.
Previous Topic:Exception starting sample application
Next Topic:MVN OSGI-Launcher cannot start
Goto Forum:
  


Current Time: Fri Sep 20 08:05:34 GMT 2019

Powered by FUDForum. Page generated in 0.01799 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top