Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Requirements Modeling Framework  » Help needed, plugin can not be installed: http://download.eclipse.org/rmf/updates/latest
Help needed, plugin can not be installed: http://download.eclipse.org/rmf/updates/latest [message #1795812] Sat, 29 September 2018 11:27 Go to next message
Sebastian Wendel is currently offline Sebastian WendelFriend
Messages: 1
Registered: September 2018
Junior Member
Dear Sir or Madam,

if I try to install the plugin with:

"Help" -> "Install new Software.." -> "Work with: http://download.eclipse.org/rmf/updates/latest"

It can not find and install the components: The installation cannot be completed as requested.

Because of that I filed a Bug: https://bugs.eclipse.org/bugs/show_bug.cgi?id=539645

I have noticed that it has an odd behavior with http://download.eclipse.org/rmf/updates/releases . It can not install the latest version 0.14 nor 0.13 , it will install 0.11 . Can anyone tell me what is going on? Is the 0.14 not available anymore, but why?

Can anyone help to resolve the problem ot tell me how I can install the plugin version 0.14? Thank you very much,

Best Regards, Sebastian

P.S.

Cannot complete the install because one or more required items could not be found.
Software being installed: RMF Core ReqIF SDK Feature (Incubation) 0.13.0.201509161042 (org.eclipse.rmf.reqif10.sdk.feature.feature.group 0.13.0.201509161042)
Missing requirement: RMF Core ReqIF Feature (Incubation) 0.13.0.201509161042 (org.eclipse.rmf.reqif10.feature.feature.group 0.13.0.201509161042) requires 'org.eclipse.equinox.p2.iu; org.eclipse.sphinx.emf.serialization.feature.group 0.8.1.201409171422' but it could not be found
Cannot satisfy dependency:
From: RMF Core ReqIF SDK Feature (Incubation) 0.13.0.201509161042 (org.eclipse.rmf.reqif10.sdk.feature.feature.group 0.13.0.201509161042)
To: org.eclipse.equinox.p2.iu; org.eclipse.rmf.reqif10.feature.feature.group [0.13.0.201509161042,0.13.0.201509161042]
Re: Help needed, plugin can not be installed: http://download.eclipse.org/rmf/updates/latest [message #1795934 is a reply to message #1795812] Tue, 02 October 2018 14:00 Go to previous message
Michael Jastram is currently offline Michael JastramFriend
Messages: 233
Registered: April 2010
Location: Düsseldorf, Germany
Senior Member
Hi Sebastian,

RMF is based on a fairly old Eclipse (Luna). If you are using a recent Eclipse, chances are that nobody updated the dependencies to ensure that it works. This is probably what you're encountering.

Your options are to either use an older Eclipse base platform, or to update the dependencies. It may be possible to fix this by finding the missing dependencies and installing them manually. Sorry I can't give you better news.

Best,
- Michael
Previous Topic:Widget has the wrong parent
Next Topic:How the ReqIF IDs are generated
Goto Forum:
  


Current Time: Sat Jan 25 01:19:24 GMT 2020

Powered by FUDForum. Page generated in 0.02015 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top