Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Installation problem(permission denied)
Installation problem [message #1795455] Sun, 23 September 2018 10:07 Go to next message
ALEXANDROS STATHAS is currently offline ALEXANDROS STATHASFriend
Messages: 1
Registered: September 2018
Junior Member
I try to install eclipe in a distro of ubuntu 18.04 in my windows 10 machine.

I installed Java

I downloaded the linux installation pachage for eclipse photon

However after I unzip the files in the ~$ directory trying the next command
./eclipse-installer/eclipse-inst

fails with the following message:
~bash: ./eclipse-installer/eclipse-inst: Permission denied

I tried to run with sudo but nothing changed

It seems very basic but as I am novice to both Ubuntu,Java, and eclipse I can't figure out what might be the problem

Re: Installation problem [message #1795477 is a reply to message #1795455] Mon, 24 September 2018 05:45 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29593
Registered: July 2009
Senior Member
I'm a little confused. If you're on Windows 10, then you need the Windows installer, not the Linux installer, even if you are using bash on Windows. But you also mention Ubuntu and sudo. How does that related to your Windows 10 machine? Does ./eclipse-installer/eclipse-inst have +x permission for the user? I would expect so...
Re: Installation problem [message #1795497 is a reply to message #1795477] Mon, 24 September 2018 10:18 Go to previous message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 403
Registered: August 2014
Senior Member
From the message it seems that the OP is running Linux. The 'Windows 10' must be some sort of confusion.

My guess is that he's running Linux on a dual-boot system or under a virtual hypervisor (e.g. VMware), and he has downloaded a Windows installer, or an installer of incorrect bitness.



--

Tauno Voipio
Previous Topic:Trouble with UMLet plug-in
Next Topic:Valid ECA do not validated at Pull Request to titan.core
Goto Forum:
  


Current Time: Thu Oct 18 03:47:41 GMT 2018

Powered by FUDForum. Page generated in 0.03900 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top