Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Paho » v1.3.0 stability?
v1.3.0 stability? [message #1795234] Tue, 18 September 2018 20:52 Go to next message
Daryl Fortney is currently offline Daryl FortneyFriend
Messages: 1
Registered: September 2018
Junior Member
New paho-c user here planning on consuming it and paho-cpp packages from conan and inheriting a project to do it that currently requires v1.2.0 which has conan packaging created by the 'conan-community'. Just noticed v1.3.0 released a few days ago and was wondering if this is stable enough to jump to for an important project or if we should stick to 1.2.0 for now? If we hold off on the 1.3.0 upgrade also wondering if 1.2.1 is also worth bumping up to?
Re: v1.3.0 stability? [message #1797407 is a reply to message #1795234] Tue, 30 October 2018 16:00 Go to previous message
Ian Craggs is currently offline Ian CraggsFriend
Messages: 76
Registered: March 2013
Member
In general the later versions are always worth updating to 1.2.1 has fixes on top of 1.2.0. 1.3.0 has the major addition of MQTT version 5.0 support, so you may want to hold off for a while as that has the largest amount of changes made for a good while, although I haven't seen any evidence of any instability introduced. I plan to release a 1.3.1 version in the next few months.
Previous Topic:paho c client remote host broker connection
Next Topic:Not able to simultaneously Publish & Subscribe
Goto Forum:
  


Current Time: Thu Oct 22 13:27:21 GMT 2020

Powered by FUDForum. Page generated in 0.01914 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top