Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Missing artifact sun.jdk:tools:jar:LATEST(Unable to find dependency)
Missing artifact sun.jdk:tools:jar:LATEST [message #1794019] Wed, 22 August 2018 14:09
john ashurst is currently offline john ashurstFriend
Messages: 1
Registered: August 2018
Junior Member
I am fairly new to Java and I have a project to play with.

This is my first time using Eclipse for Java (previously used for PHP) and I am having trouble with it finding -

Missing artifact sun.jdk:tools:jar:LATEST

I have managed to install all other dependencies and have placed the sun module in the correct folder.

It is a Maven project and I have tried updating and rebuilding etc.

I have used both the JDE and JDK without success.

I have tried adding <dependency> to the pom file as described in the sun tools website and other forums.

I have even had one of my colleagues who is a java programmer try and he is also perplexed.

The only difference is that I am on windows 10 and he is on Ubuntu.

Does anyone have any suggestions?

Previous Topic:How to search all references of a method ?
Next Topic:Eclipse does not display Chinese characters
Goto Forum:
  


Current Time: Sat Nov 17 15:58:46 GMT 2018

Powered by FUDForum. Page generated in 0.02095 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top