Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » installer crash
installer crash [message #1793477] Wed, 08 August 2018 21:59 Go to next message
Andrew Meck is currently offline Andrew MeckFriend
Messages: 1
Registered: August 2018
Junior Member
java.lang.NoClassDefFoundError: Could not initialize class org.eclipse.oomph.jreinfo.JREManager
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.createContent(SimpleVariablePage.java:344)
at org.eclipse.oomph.setup.internal.installer.SimpleInstallerPage.<init>(SimpleInstallerPage.java:91)
at org.eclipse.oomph.setup.internal.installer.SimpleVariablePage.<init>(SimpleVariablePage.java:267)
at org.eclipse.oomph.setup.internal.installer.SimpleInstallerDialog.createUI(SimpleInstallerDialog.java:252)
at org.eclipse.oomph.setup.internal.installer.AbstractSimpleDialog.show(AbstractSimpleDialog.java:139)
at org.eclipse.oomph.setup.internal.installer.InstallerApplication.run(InstallerApplication.java:250)
at org.eclipse.oomph.setup.internal.installer.InstallerApplication.start(InstallerApplication.java:408)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.base/java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:656)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:592)
at org.eclipse.equinox.launcher.Main.run(Main.java:1498)
Re: installer crash [message #1793481 is a reply to message #1793477] Thu, 09 August 2018 04:38 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 29482
Registered: July 2009
Senior Member
Is that's all that's in the log? Does the folder ~/.eclipse/org.eclipse.oomph.jreinfo exist on your file system? Are there two files in that folder? What is in each of these files? Are the these files recreated if you delete the folder and run the installer again?

If I recall correctly, some folks have "phantom" problems with write permission on files when the application quickly reads and writes the same file because the system's virus scanner can lock the file for a short period of time.
Previous Topic:Search in file, not working on new Neo install
Next Topic:filedialog requist
Goto Forum:
  


Current Time: Sat Aug 18 02:35:44 GMT 2018

Powered by FUDForum. Page generated in 0.02557 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top