Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Schema location error after update to eclipse 4.8 (EMF 2.14)
Schema location error after update to eclipse 4.8 (EMF 2.14) [message #1792470] Wed, 18 July 2018 11:09 Go to next message
Matthias Fromme is currently offline Matthias FrommeFriend
Messages: 19
Registered: December 2011
Location: Germany
Junior Member
Hello,

i have created a setup task and located its repository in the file system. As schemaLocation I'm using something like:
file:/c:\Path\To..

This works well with Eclipse 4.7.3a, but not with 4.8.0 since the Model contains an error saying that the URI is not well formed.
As I have seen in the EMF history a new check was added for this kind of annotations.

So my question is: How do I specify a valid file system schemaLocation for an oomph setup task?

Regards,
Matthias

Re: Schema location error after update to eclipse 4.8 (EMF 2.14) [message #1792496 is a reply to message #1792470] Wed, 18 July 2018 17:49 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 29534
Registered: July 2009
Senior Member
It's checked liked this
  protected static boolean isWellFormedURI(String uri)
  {
    try
    {
      return uri != null && uri.length() != 0 && uri.equals(URI.createURI(uri, true).toString());
    }
    catch (Throwable exception)
    {
      return false;
    }
  }
In general, a file URI for Windows should look like this:
 file:/D:/sandbox/USER-HOME/ecf-master/git/org.eclipse.ecf/releng/org.eclipse.ecf.releng/ECF.setup
Note that the drive letter is upper case and that \ is not a path separator in a URI.
Previous Topic:headless oomph?
Next Topic:sharing of target definitions based on targlets
Goto Forum:
  


Current Time: Tue Sep 18 15:32:31 GMT 2018

Powered by FUDForum. Page generated in 0.02466 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top