Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Photon crashes immediately after installation(Photon crashes on OS X at start)
Photon crashes immediately after installation [message #1791885] Fri, 06 July 2018 13:41 Go to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 423
Registered: August 2014
Senior Member
Photon crashes immediately after installation on OS X 10.9.5, with Oracle Java version 1.8.0_131 (and 1.8.0_172). The splash screen shows for a while, and the main loop gets an operating system trap.

There are no Eclipse logs to be found.

OS X crash report files attached.

Any pointers how to proceed?


--

Tauno Voipio
Re: Photon crashes immediately after installation [message #1792059 is a reply to message #1791885] Tue, 10 July 2018 15:46 Go to previous messageGo to next message
Patrick Moran is currently offline Patrick MoranFriend
Messages: 86
Registered: March 2018
Member
Eclipse is really good at crashing. None of my other apps frequently crash. The question for you would be whether Eclipse as currently on your system always crashes, or whether you can get a little done and saved before it crashes.

The first thing you should do is to remove the current Eclipse from your system and then download a fresh version of Eclipse, install it, and hope that removing all the old stuff will have fixed the problem. (Sometimes something goes wrong in transmission of DMG files. If the installation procedure does not detect the change then the resulting executable file will have some mistake that may cause it to crash as it attempts to load, or perhaps fail as soon as you try to do something that the application no longer can do.)

Sometimes manufacturers do not test their products on new OS and when users make, e.g., an update to High Sierra, their old software will not work. The phone application called MagicJack does not work anymore,, and the people who run MagicJack don't care. I guess they want to force early adapters of MagicJack to buy new hardware.

You could also try to copy your DMG and install Eclipse temporarily on some other Mac running High Sierra. If it works there, then the problem is some conflict on your computer. It might help to take your problem to the Genius Bar at an Apple store. Meanwhile, I guess the thing to do would be to use TimeMachine to revert to Oxygen.
Re: Photon crashes immediately after installation [message #1792218 is a reply to message #1792059] Thu, 12 July 2018 17:18 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 423
Registered: August 2014
Senior Member
Thanks for responding.

I have tried the Photon (freshly installed using the installer) on two different computers (MacBook Pro and Mac Pro), and both crash without giving a clue. From the crash message it seems that the windowing toolkit is attempting to use a dynamically linked module from OS X, and the module is not available of some reason.

Both computers run fine with Oxygen.3a, and they will be so until the issue is resolved in some way. There is a heavy chain of required updates, including a dozen of virtual machines, if I'm going to update OS X. Maybe there is the need to bite the bullet ...
--
-TV


--

Tauno Voipio
Re: Photon crashes immediately after installation [message #1792264 is a reply to message #1792218] Fri, 13 July 2018 16:19 Go to previous message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
Please create a bug report with all these details. I suggest it's an SWT issue, so here's a convenient link to get you started: https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Platform&component=SWT

Keep in mind that OS X 10.9.5 is at least 2 major releases old, so the SWT team may or may not have the resources to address the problem.

[Updated on: Fri, 13 July 2018 16:21]

Report message to a moderator

Previous Topic:SVN Checked Out Maven Project can't run JUnit Tests
Next Topic:Alert box is not showing in the center of the application using JavaFX
Goto Forum:
  


Current Time: Wed Nov 14 13:41:32 GMT 2018

Powered by FUDForum. Page generated in 0.02785 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top