Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Photon Installer "failed with an error" with no log file(Photon Installer "failed with an error" with no log file)
Photon Installer "failed with an error" with no log file [message #1791753] Wed, 04 July 2018 20:06 Go to next message
Cliff Palmer is currently offline Cliff PalmerFriend
Messages: 1
Registered: July 2018
Junior Member
When attempting to run the Oomph installer (on Windows 10 64-bit) to install photon for C/C++, the installer halts immediately after selecting "Install" with the error message "Installation failed with an error.".
I looked in the .eclipse directory under c:\users\.. and found no log files of any kind.
The Windows Event Viewer showed multiple instances of this event at the time the installer was failing:
The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
{6B3B8D23-FA8D-40B9-8DBD-B950333E2C52}
and APPID
{4839DDB7-58C2-48F5-8283-E1D1807D0D7D}
to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.
I have local administrator rights for this computer.

What should I do to find the reason for the failure?

Thanks!
Re: Photon Installer "failed with an error" with no log file [message #1791819 is a reply to message #1791753] Thu, 05 July 2018 15:07 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29545
Registered: July 2009
Senior Member
The installer executable extracts the installer application into temp folder, and if logs into configuration/*.log. If you switch to advanced mode via the menu in the upper right, it will ask if you want to keep it in a permanent location. This makes it easier to find than looking in the temp folder; you can switch back to simple mode via the toolbar at the bottom in simple mode.
Re: Photon Installer "failed with an error" with no log file [message #1791820 is a reply to message #1791819] Thu, 05 July 2018 15:09 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29545
Registered: July 2009
Senior Member
The last person who had a problem like this had file permission problems: https://www.eclipse.org/forums/index.php/t/1093973/
Re: Photon Installer "failed with an error" with no log file [message #1791821 is a reply to message #1791820] Thu, 05 July 2018 15:12 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 29545
Registered: July 2009
Senior Member
Note that problems like this can be caused by a virus scanner. I would be good to tell your virus scanner not to scan ~/.p2 and ~/.eclipse because scanners can (and often do) lock newly created or recently modified files causing phantom write permission/accessed denied problems.
Previous Topic:Hello World - Cannot create pty
Next Topic:Need help getting existing web app to eclipse
Goto Forum:
  


Current Time: Sun Sep 23 15:44:23 GMT 2018

Powered by FUDForum. Page generated in 0.03402 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top