Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » Memory Error(Memory Error while running OPC UA)
Memory Error [message #1791444] Fri, 29 June 2018 12:29 Go to next message
Anugerah Nuri Satria is currently offline Anugerah Nuri SatriaFriend
Messages: 32
Registered: September 2017
Member
I would like to ask about the error that occurs when I run a program in 4DIAC using OPC UA. When running the program, in the middle of the way an error like the attached picture, how to resolve the error? i use Raspberry Pi to run that program.
  • Attachment: 74933.jpg
    (Size: 182.67KB, Downloaded 32 times)
  • Attachment: 74934.jpg
    (Size: 165.31KB, Downloaded 29 times)

[Updated on: Sat, 30 June 2018 02:33]

Report message to a moderator

Re: Memory Error [message #1791487 is a reply to message #1791444] Sat, 30 June 2018 12:46 Go to previous messageGo to next message
Kirill Dorofeev is currently offline Kirill DorofeevFriend
Messages: 38
Registered: February 2016
Member
hi, may I ask you for a snapshot of your 4diac application that leads to this error?
Re: Memory Error [message #1791507 is a reply to message #1791487] Sun, 01 July 2018 11:34 Go to previous messageGo to next message
Anugerah Nuri Satria is currently offline Anugerah Nuri SatriaFriend
Messages: 32
Registered: September 2017
Member
This is my program for 1 server and 1 client. but i use 4 client to running all of my program.
  • Attachment: 1.jpg
    (Size: 252.72KB, Downloaded 27 times)
  • Attachment: 2.jpg
    (Size: 266.81KB, Downloaded 22 times)

[Updated on: Sun, 01 July 2018 11:36]

Report message to a moderator

Re: Memory Error [message #1791532 is a reply to message #1791507] Mon, 02 July 2018 07:24 Go to previous messageGo to next message
Jose Maria Jesus Cabral Lassalle is currently offline Jose Maria Jesus Cabral LassalleFriend
Messages: 101
Registered: February 2016
Senior Member
Hi,

which version of forte and open62541 are you using? If not, I'd try moving to the last version of them.
Re: Memory Error [message #1791540 is a reply to message #1791532] Mon, 02 July 2018 08:36 Go to previous messageGo to next message
Jose Maria Jesus Cabral Lassalle is currently offline Jose Maria Jesus Cabral LassalleFriend
Messages: 101
Registered: February 2016
Senior Member
We just pushed a fix to 1.9.x and develop regarding memory allocation. The bug was when the connection was closed, but maybe it was the root of your problem.
Re: Memory Error [message #1791563 is a reply to message #1791540] Mon, 02 July 2018 14:31 Go to previous messageGo to next message
Anugerah Nuri Satria is currently offline Anugerah Nuri SatriaFriend
Messages: 32
Registered: September 2017
Member
I use 1.8.4 version, and 0.2 OPC version. Which memory do forte use ? is it RAM ?
Re: Memory Error [message #1791682 is a reply to message #1791563] Wed, 04 July 2018 07:14 Go to previous message
Jose Maria Jesus Cabral Lassalle is currently offline Jose Maria Jesus Cabral LassalleFriend
Messages: 101
Registered: February 2016
Senior Member
Hi,

I'd suggest to move to the develop branch in forte and the 0.3 in open62541 and compile forte with these versions. The memory problem in Forte is not regarding where it runs, but something is allocated or deallocated wrongly. With the latest versions this problem might have been solved.
Previous Topic:RS232
Next Topic:Installing WAGO-PFC-BSP-2018.2.1
Goto Forum:
  


Current Time: Sun Sep 23 14:15:56 GMT 2018

Powered by FUDForum. Page generated in 0.01813 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top