Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Toolchains not showing (I think)(Toolchains)
Toolchains not showing (I think) [message #1790791] Mon, 18 June 2018 03:28 Go to next message
Jeremy Sturm is currently offline Jeremy SturmFriend
Messages: 1
Registered: June 2018
Junior Member
The title might have been a bit confusing, but I think it's the issue I'm having.
I'm following the tutorial in the documentation for Eclipse C++, but I come to a roadblock when my project is created.
<iostream> can't be found, nor can namespace std, or cout.
And going further into the tutorial revealed that these were included (I think) in the toolchains.
But when I create the project, they're not there. The only thing there is the source .cpp file.
What am I doing wrong? Here's a detailed explanation of what I'm doing.
1. Clicking new > c/c++ project.
2. Clicking c++ managed build.
3. Typing in a project name, and double clicking (just to be sure) on Empty Project and Gross GCC
4. Confirming that the project type is executable and the toolchains contains Gross GCC.
5. Clicking Finish.
That's what I'm doing, but the file's empty. Nothing inside the folder with the name of the project.
What am I doing wrong? Can someone please help me with this problem, and tell me what it is?
Re: Toolchains not showing (I think) [message #1790843 is a reply to message #1790791] Mon, 18 June 2018 21:45 Go to previous messageGo to next message
David VavraFriend
Messages: 771
Registered: October 2012
Senior Member
Don't know which version of Eclipse and CDT you have or the OS.

These are the general steps:
https://help.eclipse.org/oxygen/topic/org.eclipse.cdt.doc.user/tasks/cdt_t_proj_new.htm?cp=13_3_0


The easiest way to start a new project with managed builds is to create an HelloWorld project using a template
https://help.eclipse.org/oxygen/topic/org.eclipse.cdt.doc.user/tasks/cdt_t_proj_new_with_template.htm?cp=13_3_1

1) File --> New --> C/C++ Project --> Executable --> Hello World C++ Project
2) Select a toolchain
3) Give it a project name and location
4) Finish
5) delete (via Project Explorer) <project name> --> src --> <project name>.cpp
6) add your own code to directory <project name> --> src

<project name> --> src is the default source directory but you can change it at step (4) of the new_with_template help link.

Suggest you read https://help.eclipse.org/oxygen/topic/org.eclipse.cdt.doc.user/concepts/cdt_o_home.htm?cp=13
starting with Before you begin
Re: Toolchains not showing (I think) [message #1790895 is a reply to message #1790843] Tue, 19 June 2018 20:29 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 399
Registered: August 2014
Senior Member
David,

I suspect that the OP is attempting some kind of cross-compilation, but he has not given any details.


--

Tauno Voipio
Re: Toolchains not showing (I think) [message #1790985 is a reply to message #1790895] Thu, 21 June 2018 04:39 Go to previous message
David VavraFriend
Messages: 771
Registered: October 2012
Senior Member
Tauno,

I did what he described.
In my system at least, Cross GCC is synonymous with normal GCC unless I change it.
There is a dialog during the project creation process that allows setting the prefix and location of the cross-compiler.
There is also an Advanced dialog that brings up Project --> Properties.
The steps, though, are somewhat different than what he described.

I had to do New --> Project --> C/C++ Project --> C++ Managed Build
There I could set the project name, select Empty Project and Cross GCC.
But Finish was still grayed out.
I had to select Next which brings up a Build Configurations dialog.
I then had to select Next to bring up a dialog to set the Cross Compile command stuff.
I didn't bother adding anything but just hit Finish.
This is what I got.
index.php/fa/33186/0/
I think there may be something wrong with his installation
or it just isn't current
or he got the command for the cross compiler wrong.
In any case, the Project View folder shouldn't be empty. (see update below)
Assuming that's what he meant by "Nothing inside the folder with the name of the project. "

I still believe it's easier to create and modify an HelloWorld project than to try to configure some other.

UPDATE
I tried another project but this time gave it a bogus cross compile prefix and path.
I got a project folder that didn't have compiler builtins but it did have everything else.
index.php/fa/33187/0/

It's possible that files beginning with "." are hidden by a Project View filter
Open Project Explorer view.
Select the menu (down arrow icon on the top right)
Select Filters and Customization --> Filters tab --> .* resources
If checked then files starting with "." are hidden.
Unchecked, they reappear.

[Updated on: Thu, 21 June 2018 07:15]

Report message to a moderator

Previous Topic:Exclude (duplicate) header from project
Next Topic:Project Creation Performance
Goto Forum:
  


Current Time: Tue Sep 18 13:11:36 GMT 2018

Powered by FUDForum. Page generated in 0.01493 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top