Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » ARM Debugging in Eclipse OSX - new
ARM Debugging in Eclipse OSX - new [message #1790670] Thu, 14 June 2018 08:14
Kristine Hendricks is currently offline Kristine HendricksFriend
Messages: 1
Registered: June 2018
Junior Member
Hello all, I hope someone can help me. I am running Kepler on my Mac OSX latest OS version. I have installed the CDT package as well as many ARM toolchains but currently using the gcc-arm-non-eabi- one. The problem is that while the code compiles a debug session, when I try to debug the following message is produced:
"Error in final launch sequence
Failed to execute MI command:
tbreak main
Error message from debugger back end:
Cannot access memory at address 0x800030a
Cannot access memory at address 0x800030a"
I am using the Segger J-link applications as well as a Segger JTAG debugger, the target is the NXP LPC 1768. I suspect the problem here is in the debugger end of my setup but when running the jlink utilities by themselves, they seem to work properly. Can someone help me decode what the MI command is? I suspect that whatever it is it is not compatible with my setup.
I apologize in advance for the newbie question.
regards,

Kristine
Previous Topic:Yocto project - Remote debugging problem
Next Topic:CDT C++ Project Templates - How to not import into Workspace?
Goto Forum:
  


Current Time: Sat Sep 22 10:41:19 GMT 2018

Powered by FUDForum. Page generated in 0.04196 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top