Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » P2 » p2 issue with Citrix and roaming configuration area
p2 issue with Citrix and roaming configuration area [message #1790609] Wed, 13 June 2018 14:04
Patrick Paulin is currently offline Patrick PaulinFriend
Messages: 42
Registered: July 2009
Location: Madison, Wisconsin
Member
I'm trying to track down a p2 issue, and I'm wondering if anyone has encountered this before. The situation is:

1. An Eclipse RCP application running in a Citrix environment. The application automatically checks for and applies updates on startup.

2.. Each user has their configuration and instance areas redirected to their home directory. On Citrix, this is part of the user's roaming profile.

What we're seeing is that the update is performed successfully, the latest bundle and feature JARs are copied to the users configuration area. The problem is that the osgi.bundles property in the config.ini only lists the few bundles that were updated. When we run the application in a non-Citrix environment, the osgi.bundles property includes all of the bundles that should be loaded.

Has anyone seen behavior like this? Or do you have any idea why the config.ini in the user's configuration area would be re-written without all of the bundles?

Thanks for any help,

--- Patrick


Patrick Paulin
Eclipse RCP/OSGi Trainer and Consultant
Modular Mind, Ltd.

patrick@modumind.com
www.modumind.com
twitter.com/pjpaulin
linkedin.com/in/pjpaulin
Previous Topic:p2.mirror task fails when using iu with specific version
Next Topic:Bundling JRE in a feature
Goto Forum:
  


Current Time: Mon Nov 12 22:19:03 GMT 2018

Powered by FUDForum. Page generated in 0.01209 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top